I have a problem with postfix that I can´t send by outlook 365, I can download the emails by pop/imap but not send.

All the other tools I tested worked, google smtp, thunderbird, applemail … But not outlook, this is taking my sleep.

Does anyone know a solution?

1 comment
  • I solved it! If anyone else has this problem just need to add auth_mechanisms to /etc/dovecot/dovecot.conf and restart dovecot.

    auth_mechanisms = plain login
    

    That way he will be able to log in smtp to outlook on mac.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Thanks! It is working!
This issue occur me a headache a long time ago...........

The biggest question: if we are talking about SMTP (postfix), why Dovecot bring the solution?

  • Dovecot is responsible for managing the mailboxes on the server, while Postfix sends the emails through the SMTP protocol.

    I think if Dovecot does not allow login postfix will not send the emails. But I’m not sure.

Hello,

As described in this answer here I would recommend checking your logs for more information.

Run this command:

tail -f /var/log/mail.err /var/log/mail.log /var/log/dovecot.log /var/log/spamassassin/spamd.log

And then try to authenticate via Outlook and try to send an email. This should populate the logs and the information would give you a good starting point for further troubleshooting.

Let me know how it goes!
Regards,
Bobby

  • These commands do not work on my system. But I have the postfix logs.
    Error message:
    https://pastebin.com/UZr5QnXN
    Message successfully:
    https://pastebin.com/4kavaAZ0

    I changed the email names and ips for privacy.

    The ports are open:

    COMMAND   PID    USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME
    master  11356    root   18u  IPv4 11361836      0t0  TCP *:submission (LISTEN)
    master  11356    root   19u  IPv6 11361837      0t0  TCP *:submission (LISTEN)
    smtpd   15250 postfix    6u  IPv4 11361836      0t0  TCP *:submission (LISTEN)
    smtpd   15250 postfix    7u  IPv6 11361837      0t0  TCP *:submission (LISTEN)
    

    I also found out that it is a mac/os outlook specific issue, unfortunately microsoft didn’t want to support me.

    • Hello,

      This indeed sounds like a Mac Outlook specific problem as I’m unable to find anything specific in the logs that could be pointing to a configuration problem.

      Have you tried using the Mac Mail instead to see if that works?

      Regards,
      Bobby

      • Yes, all other email programs work. Apple mail, thunderbird, google smtp … until outlook on iphone.

        I solved adding auth_mechanisms to /etc/dovecot/dovecot.conf and restart dovecot.

Submit an Answer