Question

postgres packages not found during install

  • Posted June 8, 2013

I was referred to this article http://hendrelouw73.wordpress.com/2012/11/14/how-to-install-postgresql-9-1-on-ubuntu-12-10-linux/ by someone on this forum for installing Postgres on ubuntu, but when I tried to install 9.2.3 (rather than 9.1 version described in the article), I ran into the following problem

sudo apt-get install postgresql-9.2.3 Reading package lists… Done Building dependency tree
Reading state information… Done E: Unable to locate package postgresql-9.2.3 E: Couldn’t find any package by regex ‘postgresql-9.2.3’

I then tried to install 9.2 (leaving off the 3 at the end) like below but ran into a different problem.

sudo apt-get install postgresql-9.2 Reading package lists… Done Building dependency tree
Reading state information… Done Package postgresql-9.2 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package ‘postgresql-9.2’ has no installation candidate

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Digging a bit further I belive there is a ppa for you here: http://askubuntu.com/questions/186610/how-do-i-upgrade-to-postgres-9-2

A lot of time the mainline ubuntu repositories won’t update to the bleeding edge of versions of software. So 9.2 was probably release sometime after 12.10 (October, 2012) and thus wasn’t included into the mainline. <br> <br>You can try adding the ubuntu “backports” repo which sometimes takes newer versions of packages from newer releases and puts them into old repos (For example if postgres 9.2 was in 13.04) <br> <br>You can also look for a “ppa” ubuntu repo. These are smaller repositories for a few packages that ubuntu community people package up as the need arises. <br> <br>Finally, if you must have postgres9.2 you can always compile from the source. I would recommend apt-get removing the current version of postgres and then installing from source.

Update <br> <br>I ran the following <br> <br>apt-get update && apt-cache search ^postgresql-9 <br> <br>and got this output. Not sure if it means that nothing higher than 9.1 is available to install. Since I have 9.2.3 on my Mac, I wonder why that’d be. <br> <br> <br> <br>Ign http://security.ubuntu.com quantal-security InRelease <br>Ign http://archive.ubuntu.com quantal InRelease <br>Hit http://security.ubuntu.com quantal-security Release.gpg <br>Ign http://archive.ubuntu.com quantal-updates InRelease <br>Hit http://security.ubuntu.com quantal-security Release <br>Hit http://archive.ubuntu.com quantal Release.gpg <br>Get:1 http://archive.ubuntu.com quantal-updates Release.gpg [933 B] <br>Hit http://security.ubuntu.com quantal-security/main i386 Packages <br>Hit http://archive.ubuntu.com quantal Release <br>Get:2 http://archive.ubuntu.com quantal-updates Release [49.6 kB] <br>Hit http://security.ubuntu.com quantal-security/main Translation-en <br>Hit http://archive.ubuntu.com quantal/main i386 Packages <br>Hit http://archive.ubuntu.com quantal/universe i386 Packages <br>Ign http://security.ubuntu.com quantal-security/main Translation-en_US <br>Hit http://archive.ubuntu.com quantal/main Translation-en <br>Hit http://archive.ubuntu.com quantal/universe Translation-en <br>Get:3 http://archive.ubuntu.com quantal-updates/main i386 Packages [259 kB] <br>Get:4 http://archive.ubuntu.com quantal-updates/universe i386 Packages [192 kB] <br>Hit http://archive.ubuntu.com quantal-updates/main Translation-en <br>Hit http://archive.ubuntu.com quantal-updates/universe Translation-en <br>Ign http://archive.ubuntu.com quantal/main Translation-en_US <br>Ign http://archive.ubuntu.com quantal/universe Translation-en_US <br>Ign http://archive.ubuntu.com quantal-updates/main Translation-en_US <br>Ign http://archive.ubuntu.com quantal-updates/universe Translation-en_US <br>Fetched 501 kB in 3s (148 kB/s) <br>Reading package lists… Done <br>postgresql-9.1 - object-relational SQL database, version 9.1 server <br>postgresql-9.1-dbg - debug symbols for postgresql-9.1 <br>postgresql-9.1-debversion - Debian version number type for PostgreSQL <br>postgresql-9.1-ip4r - IPv4 and IPv4 range index types for PostgreSQL 9.1 <br>postgresql-9.1-orafce - Oracle support functions for PostgreSQL 9.1 <br>postgresql-9.1-pgfincore - set of PostgreSQL functions to manage blocks in memory <br>postgresql-9.1-pgmemcache - PostgreSQL interface to memcached <br>postgresql-9.1-pgmp - arbitrary precision integers and rationals for PostgreSQL 9.1 <br>postgresql-9.1-pgpool2 - connection pool server and replication proxy for PostgreSQL - modules <br>postgresql-9.1-pljava-gcj - Java procedural language for PostgreSQL 9.1 <br>postgresql-9.1-pllua - Lua procedural language for PostgreSQL 9.1 <br>postgresql-9.1-plproxy - database partitioning system for PostgreSQL 9.1 <br>postgresql-9.1-plr - Procedural language interface between PostgreSQL and R <br>postgresql-9.1-plsh - PL/sh procedural language for PostgreSQL 9.1 <br>postgresql-9.1-postgis - Geographic objects support for PostgreSQL 9.1 <br>postgresql-9.1-prefix - Prefix Range module for PostgreSQL <br>postgresql-9.1-preprepare - Pre Prepare your Statement server side <br>postgresql-9.1-slony1-2 - replication system for PostgreSQL: PostgreSQL 9.1 server plug-in