Question

PostgreSQL on Private Network Not connection

Been working through the tutorials, google, everything I can find to figure out why my Postgres server won’t talk with the other droplets on the account. SSH does work between all the droplets, Postgres does not.

listen address is setup to the private network address (even tried with *). HBA file has all other droplets private addresses (even tried with allow all addresses) Tried with UFW both on and off. Can connect on machine from CLI but not from others.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Nope. The issue was a setting. Also using the Cloud Firewalls and didn’t realize they also work on the private interface as well as the public one.

A case of being over secure by accident.

Hey friend,

While I’m not a heavy Postgres user myself, I found this tutorial and it’s leading me to believe that there may be just a bit more necessary than bind address and an open port, does this tutorial seem at all helpful?

https://blog.bigbinary.com/2016/01/23/configure-postgresql-to-allow-remote-connection.html

My apologies if not.

Jarland