Question

Private connection to Managed DB not working from within same region droplet.

I have a droplet in the same region as my managed DB, like DO suggested. I have added my IP and droplet to the Restricted Access section of the managed database. I can connect via public connection from my computer. If I try connecting from within the droplet using private credentials, no error message, just timeout. Is there a step I’m missing? I even disabled the droplet’s firewall thinking the port was being blocked.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

In case anyone is still having this issue here are some steps to take that will solve this for you.

A couple of things to keep in mind your droplets have to be in the same region as the managed DB to use the private connection.

Now, if that’s all set here’s the next steps. This makes the assumption that you are adding private networking after already having created your managed db.

Step 1 - If you’ve enabled Private Networking for your droplet and followed the instructions to add the private IP address you can SSH into your droplet and use the Connection String with Flags to make sure you’re managed DB knows to let your droplet traffic through.

Step 2(A) - It worked? Great! Your app is probably not configured correctly to use the private connection.

Step 2(B) - The connection is still timing out? No worries, copy the private IP address of the droplet and then navigate to your managed DB settings, then add the private IP address as under “Trusted sources”, make sure you specifically use the IP address, and then save.

Step 2© - Test your connection using Connection String > Flags again from your droplets ssh session. You should now be connecting!

For some reason, it appears that using the tags does not add the private IP to the managed DB’s trusted sources list, but adding it manually works. This isn’t very scalable though 🤔😡

Hi everyone, I believe that private networking access is also limited to droplets on the same region and account. If you try to connect from another Digital Ocean account, it will not work.

If you added private networking after your droplet was created, you have to enable it manually:

https://www.digitalocean.com/docs/networking/private-networking/how-to/enable/#network-configuration-by-operating-system

This fixed my issue.