private-network is not correctly set on droplets

November 29, 2015 4.3k views
Networking Getting Started CentOS

After creating 2 droplets(CentOS 7), and booting the system, I powered them down, added private network to them, which DO portal showed its addresses correctly.
But ifconfig command for eth1 did not have any of that IP address, just showing the IPv6 address.
I added the private IP address with ifconfig to eth1, which provided private IP to the instance(droplet), but since there is no file under /etc/sysconfig/network-scripts/ for ifcfg-eth1, most probably every time I reboot the instance, I have to re-assign the private IP to the instance. which can be counter-productive.
Could you please let me know which step I am missing here. Thanks.

2 Answers

@saeed

If you'll drop by the link below and look for the header "CentOS & Fedora", it'll provide you with the correct way to get the Private Network up and running :-). There's a specific method you need to use when adding the interface and you need to make sure that you reboot after performing the changes as well (this reboot would be in addition to the one performed through the control panel to gain the IP).

https://www.digitalocean.com/community/tutorials/how-to-enable-digitalocean-private-networking-on-existing-droplets

by Melissa Anderson
DigitalOcean offers shared private networking for Droplets in all data centers at no additional charge. When private networking is enabled as part of creating a Droplet, it is automatically configured. If it's not set up when the Droplet is created, it can be enabled manually. In this article, we'll explain how to enable and manually configure private networking for Droplets that were created without private networking.

Adding the ifcfg-eth1 file manually resolved the concern of reboot and IP assignment for private interface.
Thanks @jtittle

Have another answer? Share your knowledge.