Private Networking Not Working

February 1, 2018 2.6k views
Networking Ubuntu 16.04

So I got private networking. MY server was already made and in use and I decided to enable private networking on my servers. They do not communicate together.

I followed the guides, adding this to /etc/network/interfaces
auto eth1
iface eth1 inet static
address 10.137.80.219 Other servers ip 10.137.136.57
netmask 255.255.0.0

Did extensive testing between my servers. But had no luck at all, they don't ping via the private ips, only public ips, and that are infact in the same datacenter

Now things are just getting worse.

As now the interface isn't showing up, if I forcefully start it with ifconfig, no network information shows up. Basically It's worse than before following guides.

I have waited for 48 hours for Digital ocean to respond after they told me what to try and they still have not responded...very very poor customer support. Does the community have any answers?

PS. It's all on Ubuntu 16.04-17.04

11 Answers

Same problem here. There is no eth1 interface listed by ifconfig
I am using Ubuntu LTS.

same problem here, have 3 droplets, one of them dont ping anymore

@jvmmdev Did you ever figure out what it is?

Hey guys.

For all that was wondering. I never resolved this. I got sick of waiting for Digital ocean to respond to my ticket once a day...if that. I waited 3 days for them to respond. To which is was never resolved.

So I just destroyed my droplets and re-install 2 with private networking simultaneously.

Problem fixed.

Yes, adding private network on prior created instances not working, we have tried several ways to make the private networking work with initially crated instances, nothing work,

only possible solution is to destroy and create again.

I had the same issue and nothing helped. I decided to enable ipv6 and that, somehow, made eth1 start showing up when I run ifconfig -a.

You might want to look for the interface under different names.

I just had the same problem, I can't find eth1.

if I run

lshw -class network

I do find disabled networks like *-network:1 disabled

Cross referencing the Mac address from the network with ifconfig I found the interface is actually called ens4 . Running ifconfig ens4 up and then reconfig /etc/network/interfaces.d/50-cloud-init.cfg works, now private networking is working.

Solution steps are explained in great detail here: https://www.digitalocean.com/docs/networking/private-networking/how-to/enable/

As the previous poster mentioned, the device is there, just disabled. The linked article explains how to set it up after droplet creation.

I ran into the same problems with Ubuntu 16.04 LTS ..old install trying to make a private network
but I managed to get it to work by following the steps for Ubuntu 14.04 ... I think there is a problem with the tutorial

The same issue, no eth1 seen. The toturial is useless.
Anyone can help?

Have another answer? Share your knowledge.