Question

Problem 403 in rails app with nginx.

Hello guys.

I configured my Nginx to run passenger with Nginx module. My PHP applications work normally.

In my nginx.conf file I put the following:

server {        listen 80;        server_name mywebsite.com www.mywebsite.com;        root /var/ www/mywebsite.com/current/public;        passenger_enabled on; }

In the public folder I ran “chmod-R 755 public” and then immediately “chown www-data: www-data public.”

'm Having 403 error.

“403 Forbidden nginx/1.6.0”

In my error.log I can see this.

2014/05/23 13:04:16 [error] 23505#0: *295 directory index of “/var/www/mywebsite.com/public_html/current/” is forbidden, client: <myip>, server: mywebsite.com, request: “GET / HTTP/1.1”, host: “mywebsite.com

What am I doing wrong? My regards. Renato


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I solved the problem. The problem was the wrong address to passenger_root. <br> <br>I fixed and worked! xD

Thanks for your answer. I tried this, but doesn’t work too. <br> <br>Help me!!

Try this, its different from the one you used. <br><pre>chown -R www-data:www-data public</pre>