Question

Problem adding a worker to the swarm

I have 2 nodes, node1 and node2. No firewall.

NODE1 CMD0 - docker swarm init --advertise–addr ip_node1

NODE2 CMD1 - docker swarm join–token SWMTKN… ip_node1:2377 “Error response from daemon: Timeout was reached before node joined. The attempt to join the swarm will continue in the background. Use the “docker info” command to see the current swarm status of your node.”

CMD2 - docker info “Swarm: error NodeID: Error: rpc error: code = DeadlineExceeded desc = context deadline exceeded Is Manager: false Node Address: 111.11.111.11"”

In /var/log/syslog msg=“failed to retrieve remote root CA certificate”

I made etc/systemd/system/docker.service.d/http-proxy.conf CMD3 - systemctl show --property=Environment docker "Environment=NO_PROXY=localhost,127.0.0.1,ip_node1!

I tryed CMD1 and it gave me the same error,could someone please tell me what I am doing wrong?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

I’ve had a similar issue in the past, what I did wrong back then was that I used an incorrect IP address when running the docker swarm init --advertise-addr your_dorplet_ip_here command.

I would recommend running the command again and see how it goes.

Another thing that I could suggest is again making sure that you don’t have a firewall like ufw enabled which could be causing that problem for you.

Regards, Bobby