Question

Problem adding addon domain in cpanel

  • Posted July 9, 2013

I have installed cpanel on centos and changed my domain name server to ns1.digitalocean.com ns2, ns3. I am able to go to my main domain and every thing works fine with it, but when I try addind an addon domain it gives the following domain

Using nameservers with the following IPs: 141.0.170.89,198.199.95.114,198.199.120.125 Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.

Now I am a complete noob in linux and vps , the above message for me is a rocket science. Any help is appreciated.

Thanks

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Check out: <a href=“http://lmgtfy.com/?q=Sorry%2C+the+domain+is+already+pointed+to+an+IP+address+that+does+not+appear+to+use+DNS+servers+associated+with+this+server.+Please+transfer+the+domain+to+this+servers+nameservers+or+have+your+administrator+add+one+of+its+nameservers+to+%2Fetc%2Fips.remotedns+and+make+the+proper+A+entries+on+that+remote+nameserver”>http://lmgtfy.com/?q=Sorry%2C+the+domain+is+already+pointed+to+an+IP+address+that+does+not+appear+to+use+DNS+servers+associated+with+this+server.+Please+transfer+the+domain+to+this+servers+nameservers+or+have+your+administrator+add+one+of+its+nameservers+to+%2Fetc%2Fips.remotedns+and+make+the+proper+A+entries+on+that+remote+nameserver</a> <br> <br>Here is one possible solution I came across: <br> <br>Logon to WHM <br>Select Tweak Settings under Server Setup <br>Put checkboxes next to both: Allow Creation of Parked/Addon Domains that are not registered <br>Allow Creation of Parked/Addon Domains that resolve to other servers (ie domain transfers) [This can be a major security problem. If you must have it enabled, be sure to not allow users to park common internet domains.]

Check out: <a href=“http://lmgtfy.com/?q=Sorry%2C+the+domain+is+already+pointed+to+an+IP+address+that+does+not+appear+to+use+DNS+servers+associated+with+this+server.+Please+transfer+the+domain+to+this+servers+nameservers+or+have+your+administrator+add+one+of+its+nameservers+to+%2Fetc%2Fips.remotedns+and+make+the+proper+A+entries+on+that+remote+nameserver”>http://lmgtfy.com/?q=Sorry%2C+the+domain+is+already+pointed+to+an+IP+address+that+does+not+appear+to+use+DNS+servers+associated+with+this+server.+Please+transfer+the+domain+to+this+servers+nameservers+or+have+your+administrator+add+one+of+its+nameservers+to+%2Fetc%2Fips.remotedns+and+make+the+proper+A+entries+on+that+remote+nameserver</a> <br> <br>Here is one possible solution I came across: <br> <br>Logon to WHM <br>Select Tweak Settings under Server Setup <br>Put checkboxes next to both: Allow Creation of Parked/Addon Domains that are not registered <br>Allow Creation of Parked/Addon Domains that resolve to other servers (ie domain transfers) [This can be a major security problem. If you must have it enabled, be sure to not allow users to park common internet domains.]

Hello, all

All you need to do is to allow the creation of remote domains via WHM’s Tweak Settings.

Login to WHM --> Server Configuration --> Tweak Settings --> Domains tab and look for the Allow Remote Domains and enable it.

Allow creation of parked/addon domains that resolve to other servers (e.g. domain transfers) This can be a major security problem. If you must have it enabled, be sure not to allow users to park common Internet domains.

Once this is enabled just go ahead and add your domain.

Hope that this helps! Regards, Alex

Domains are under cloudflare so not using server set nameservers. Doesn’t allow me to addon the domains.

@hypertextsol: I’m having this problem, too. :( On my other server from another company, I successfully added a new domain by following this guide - http://blogerr.net/adding-addon-domains-and-subdomains-to-your-web-hosting-account/ - but on my linux server with DigitalOcean, I keep getting the same error message as you. I tried checking “/etc/ips.remotedns” but it’s empty.

The solution is to add the file /etc/ips.remotedns IF it doesn’t exist and add at least 1 of the IP addresses belonging to one of the Name Servers you want to use. <br> <br>Login via SSH as root and do the following: <br> <br>pico /etc/ips.remotedns <br> <br>Add at least 1 of the IPs (or both) then CTRL-O + ENTER to save. <br> <br>Try adding your domain again via cPanel. <br> <br>You shouldn’t need to change the WHM settings via Tweak Settings as suggested. That should only be a last resort. <br>

@pablo I have re-installed virtualmin and trying to create a domain1.com webiste, but when I have created the virtual sever and visit the website domain1.com it provides this error message-- “You don’t have permission to access / on this server.”, can you please solve this problem.

RE: Virtualmin did you follow these steps? <br> <br>1.) <a href=“http://www.virtualmin.com/documentation/tutorial/how-to-create-ftp-account”>How to create an FTP account</a>. <br> <br>2.) <a href=“http://www.virtualmin.com/documentation/tutorial/how-to-create-email-account”>How to create an email account</a> <br> <br>3.) <a href=“http://www.virtualmin.com/documentation/tutorial/how-to-create-a-sub-server”>How to create a sub-server</a> <br> <br>As for another cPanel alternative, have you seen this?: <a href=“https://www.digitalocean.com/community/articles/how-to-install-zpanel-on-centos-6”>How to Install zPanel on CentOS 6</a>