Question

Problem in getting SSL Certificate through Let's Encrypt

Hi I was trying to get SSL certificate for my domain on PhpMyAdmin Droplet by following the steps mentioned at “https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04”. My server is Ok. I have DNS A entry for my domain.com and CNAME entry for my www.domain.com

As I went to execute sudo certbot --apache -d your_domain -d www.your_domain It asked me to enter email address and after that it gave me the following error.

An unexpected error occurred:
The client lacks sufficient authorization :: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430 for details.

I tried with root and non root admin user with sudo but still the same. Any help is appreciated Best


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thank you very much bobbyilive I will look into the link too. I also just discovered that you need to run
sudo apt update sudo apt install --only-upgrade certbot before you run sudo certbot --apache -d your_domain -d www.your_domain and it works Thank you very much for your support

Hello,

I believe that Let’s Encrypt ACMEv1 protocol is no longer supported and you should upgrade to an ACMEv2.

You can take a look at the answer here on how to do that:

https://www.digitalocean.com/community/questions/let-s-encrypt-acmev1-protocol-you-should-upgrade-to-an-acmev2

Hope that this helps! Regards, Bobby