Problem installing odoo 8 (openERP) on digitalocean CentOS 6.5 x32 droplet

Posted September 24, 2014 12k views

I have installed postgresql via yum and installed odoo 8 via rpm downloaded from
Everything installed fine with no error.

sudo service openerp start did not do anything. Having a look inside /etc/init.d/openerp and saw that the DAEMON path is incorrect, so I replaced DAEMON=/usr/bin/openerp-server with DAEMON=/usr/local/bin/openerp-server

Then trying to start openerp service, received error on start-stop-daemon. Googled this and installed start-stop-daemon. Now sudo service openerp start says Starting openerp: ok, but openerp is not running! No service is running on port 8069.

No log file available in /var/log/odoo so not sure as to what is wrong.

Running /usr/local/bin/openerp-server directly from bash gave the following error:
ImportError: No module named openerp

Googled this and saw that quite a few people had the same error but couldn’t find solution.

Please advise. Thanks.

1 comment
  • It appears that odoo 8 requires python 2.7, so I have installed python 2.7 following this digitalocean article (

    Then I modified the /usr/local/bin/openerp-server to use #!/usr/bin/python2.7 instead of #!/usr/bin/python

    Still getting the same error on No module named openerp but also getting this message:
    Could not find platform dependent libraries <exec_prefix>
    Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]

    So I added PYTHONHOME=/usr/local/lib/python2.7 to environment variable
    Now the message on exec_prefix and $PYTHONHOME are gone but getting different module error
    ImportError: No module named site

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

I’ve been struggling setting up odoo on a centos 6 and 7 vps too. Few days ago I found an article on how to install odoo 8 in centos 7 which worked just fine..

so, you may want to try it and see if it will work for you.

try to install from source, don’t use .deb or .rpm