Problem pointing namecheap domain with droplet IP

July 8, 2018 510 views
DNS Ubuntu 16.04

I am trying to point the droplet with IP 46.101.95.249 to domain babyhealthandsafety.me
I have followed these instructions https://www.digitalocean.com/community/tutorials/how-to-point-to-digitalocean-nameservers-from-common-domain-registrars and confirmed with namecheap the nameservers are correct but I'm still getting an ERREMPTYRESPONSE on the page. I'm not a programmer and this is driving me mad, it's so hard to get support from digital ocean!

2 Answers

Hello friend!

The DNS settings look fine, but it is important to note that it can be up to 48 hours before your local DNS resolver updates to reflect the changes. In all honesty it is usually closer to 4-6 hours, but a new .me registration does tend to be closer to the 12-24 hour range.

Though I am seeing the DNS set correctly, the droplet itself does not have a web server listening and therefore there is currently no website loading. I can ping the droplet so I know that it is online, it seems that the software is either not yet installed or you may have turned the software off while you were working on it.

Kind Regards,
Jarland

  • I think there's a problem with the webserver. I can see this:

    • Rebuilt URL to: 46.101.95.249/
    • Trying 46.101.95.249...
    • TCP_NODELAY set
    • Connected to 46.101.95.249 (46.101.95.249) port 80 (#0) > GET / HTTP/1.1 > Host: 46.101.95.249 > User-Agent: curl/7.54.0 > Accept: / < HTTP/1.1 200 OK < Server: nginx

    But I get no output if I run, for example:

    which nginx

You might also try to see if namecheap has their own DNS manager that you can use to point your domain to that IP. I've found those to be faster. Secondly, you might want to do ipconfig flushdns to clear your local dns cache.

Cheers,
Michael Paltayan
ZoomAdmin.com Founder
ZoomAdmin makes VM management easier!

  • When I run that I ge:

    No command 'ipconfig' found, did you mean:
    Command 'ifconfig' from package 'net-tools' (main)
    Command 'iconfig' from package 'ipmiutil' (universe)
    Command 'iwconfig' from package 'wireless-tools' (main)
    ipconfig: command not found

Have another answer? Share your knowledge.