Problem securing phpMyAdmin with htaccess & htpasswd

June 8, 2015 18k views
LAMP Stack MySQL PHP Ubuntu Security

Fresh Droplet :
UBUNTU 14.04.x64
LAMP 14.04

I’ve followed the instuctions provided on :

But somehow it doesn’t work.
If i go to http://MY_IP_ADDRESSS/phpmyadmin/
no window prompted to input username and password.

I’ve check the phpmyadmin.conf, .htaccess and .htpasswd files and all of those files seems good.


<Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php
    AllowOverride All


AuthType Basic
AuthName "Restricted Files"
AuthUserFile /etc/phpmyadmin/.htpasswd
Require valid-user



What is wrong ?

3 Answers

Never mind finally got this thing works.

We need to add the configuration to our web/domain configuration file ( domain.tld.conf )
in this case the domain.tld is my primary domain (i’ve use mutlple domain on 1 droplet)

Find and edit file via SSH or FTP:

Then add following configuration to the file :

<Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php
    AllowOverride All

Save , restart apache

sudo service apache2 restart

Hope this can help anyone who have the same problem.

Note :
If your main domain is and you’ve set virtual host for it
then your web/domain configuration file is


Welcome to DigitalOcean.

Where did you saved .htaccess and .htpasswd

Thx for info dude.

Idk why they don’t say about it in tutorials.

Have another answer? Share your knowledge.