Problem updating wordpress adress (URL) and site adress (URL)

November 14, 2014 2.6k views

Hi. I'm trying to make a one-click install wordpress in my droplet (Active 512MB Ram 20GB SSD Disk new york WordPress on Ubuntu 14.04) and following this tutorial:

I folow everything right: ssh to my droplet > get the .htaccess password > create my wordpress user and password > finish my wordpress installation > set my registar (gandi) to foward my domain to my droplet IP

And then, when I Update my Wordpress Address (URL) and Site Address (URL) to my domain/hostname ("" in my case), the system goes back to http://(droplet-IP)/wp-login.php screen to login again.
but then I just cant login anymore, my user dont work and recovering my password by email dont work either.
What am I doing wrong?

1 comment
  • Ok. I can acess phpmyadmin, go to my database > wp_options and change the values of Wordpress Address (URL) and Site Address (URL) back to how it was originally, ip adress instead of domains.
    The Site Adress (URL) (called 'home' in phpmyadmin) i can point to my domain with no problem.

    The Wordpress Adress (URL) (called 'siteurl' in phpmyadmin) is set to my ip adress now. If i change it to my domain, then the problem happens, i go to wp-login.php screen but my user don't work anymore....

    I need a light!

1 Answer

Go to yourip/wp-admin/options-general.php
& change wordpress url & site url to your domain

  • The problem is that right after I change wordpress url & site url, i'm redirected to the login page and can't login with my user anymore, or even use the password recovering by email.
    I do have acess via ssh to the droplet and the WP installation.

    Maybe the problem is related to this message that appears when I ssh to my droplet:

    "Make sure to specify hostname from DO panel to your droplet before creating it (for example: '' or '')
    This will create necessary Apache configs based on hostname and Apache will respond based on hostname.
    Server will also respond to its IP address, so if you finish installation from http://IP then
    you will need to change hostname from Wordpress Settings later (from http://IP to http://hostname)

    but my hostname in DO panel was set with my domain:

  • if you have phpmyadmin installed you can:

    browse to your database on the left
    click on the table "wp-options"
    you should see a field with optionname "siteurl" -change the optionvalue to or whatever.

    then find the option_name "home" and update that to or whatever it is.

    save, now try to login. You should be able to get in okay. Install the plugin for Velvet Blues URL updater and run that will clean up any other URL's

  • Thanks.
    I went to phpmyadmin and changed the option_name "home" to my domain, "siteurl" was already set.
    But still, I can't login to my user in wp-login.php.... looks like my user is gone, i don't know...
    Have no idea whats wrong, but googling, i see is kind of a common issue that people can't login after changing the url in wordpress. Still don't no the fix for my case...

  • in phpmyadmin, you can also go to the wp_users table and see if your user is there.

    If so, you can try changing the password in the database to: 81dc9bdb52d04dc20036dbd8313ed055

    which will make your password 1234 when you try to login

Have another answer? Share your knowledge.