Question

Problem with codeigniter routing

I have this website: https://oneclickpy.com/ The homepage is working fine. But no one of the other pages works :(

My config.php: $config[‘base_url’] = “https://oneclickpy.com”; $config[‘index_page’] = ‘’; $config[‘uri_protocol’] = ‘AUTO’;

My routes.php: $route[‘default_controller’] = “home”; $route[‘admin’] = “admin/login”; $route[‘apple’] = “home/apple”; $route[‘xiaomi’] = “home/xiaomi”; $route[‘samsung’] = “home/samsung”;

My .htaccess: RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond $1 !^(index.php|assets|upload|robots.txt|..css) RewriteRule ^(.)$ index.php?/$1 [L]

Rewrite mod is enabled on VPS.

It was working fine in other hosting, but not on DO. When I open the website home, it’s ok. But when trying to open other pages (like “apple”, “samsung”), I got 404 error.

What can I do?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @rickfontoura,

I believe that you need to enable AllowOverride in order for your .htaccess to take effect.

To do that you need to add the following in your Vhost:

        <Directory /var/www/oneclickpy.com/public>
                Options Indexes FollowSymLinks
                AllowOverride All
                Require all granted
        </Directory>

Note that you need to update the /var/www/oneclickpy.com/public part to match your document root.

Then run a config test and restart Apache.

After that the rules that you have in your .htaccess file would take effect.

Hope that this helps! Regards, Bobby