Problem with Email server (Postfix error)

July 25, 2013 5.4k views
Hello. I tried to install posfix on my server to send and receive email. There were some problems with gmail messages getting into spam folder. I put MX and TXT records in DNS + installed SPF on server. Now i can send email with postfix ( dont know how, but after this no messages in spam folders) but still could not receive any ( for ex. from @gmail acc to my web@site.net) sudo mail says - no new messages + this is from maillog file postfix/smtpd[3316]: fatal: need service transport:endpoint instead of "check_policy_service" postfix/master[3313]: warning: process /usr/libexec/postfix/smtpd pid 3316 exit status 1 postfix/master[3313]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling Here if my full main.cf file: queue_directory = /var/spool/postfix command_directory = /usr/sbin daemon_directory = /usr/libexec/postfix data_directory = /var/lib/postfix mail_owner = postfix inet_interfaces = all inet_protocols = all mydestination = $myhostname, localhost.$mydomain, localhost unknown_local_recipient_reject_code = 550 alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases debug_peer_level = 2 debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5 sendmail_path = /usr/sbin/sendmail.postfix newaliases_path = /usr/bin/newaliases.postfix mailq_path = /usr/bin/mailq.postfix setgid_group = postdrop html_directory = no manpage_directory = /usr/share/man sample_directory = /usr/share/doc/postfix-2.6.6/samples readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES myhostname = site.net mydomain = site.net smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination, check_policy_service,check_policy_service unix:private/policy-spf policy_time_limit = 3600 I dont know why he didnt like this line: smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination, check_policy_service,check_policy_service unix:private/policy-spf This is from SPF install FAQ + What i should do to make good Web-mail server for my users? Sorry for my English :) Thanks.
8 Answers
First check your firewall settings, and ensure that both inbound and outbound traffic is allowed on port 25. If you are still getting the error message, then open up /etc/postfix/main.cf and look for the following line:
inet_interfaces = localhost



and make sure it's commented out.
This line should be inet_interfaces = localhost?
I have -
inet_interfaces = all
and how to check firewall settings with allowed traffic on 25 port?
"This line should be inet_interfaces = localhost?"
No, it should be commented out.

"how to check firewall settings with allowed traffic on 25 port?"
Check out How to Setup a Firewall with UFW on an Ubuntu and Debian Cloud Server
by Shaun Lewis
Learn how to setup a firewall with UFW on an Ubuntu / Debian cloud server.
"how to check firewall settings with allowed traffic on 25 port?"
From info:
DigitalOcean droplets usually come with the empty configuration: all traffic is allowed.
"No, it should be commented out."
I already commented out this lane with "inet_interfaces = all" in it
I see that port 25 is open on your droplet, try sending an email again. Does it work now?
Yes. It seems that 25 is closed.
How i can open 25 and all other POP3 and IMAP ports on CentOS?
Only with iptables? What should i write there?
Port 25 is not closed - I can access it:

telnet yourdroplet'sIPaddress 25


I was able to connect successfully. Try sending an email again, does it bounce back? (you'll get a delivery failed email if it did).

Check /var/log/mail.err for errors. Do you find anything?
Yes. I got bounced message:
The recipient server did not accept our requests to connect. Learn more at http://support.google.com/mail/bin/answer.py?answer=7720
[(0) site.com. [xx.xx.xx.xx]:25: Connection timed out]
Have another answer? Share your knowledge.