Question

Problem with my console access (login does not work)

Hey guys, I am new on digitalOcean, I’ve created a new droplet and I received a login and password on my email. I use it on console access, but it does not work. I reset my password and I entered the password that I’ve receved without pasting (The password is entered) but it still not works… it says : login incorrect! Help me please…

Subscribe
Share

I managed to login after i read the following “Note When the console boots up, there is a chance that it will read the state of your SHIFT key for certain characters incorrectly. In particular, your number keys may show their alternate functions. To reset this behavior and ensure that your key strokes are being received correctly, hit the SHIFT and CTRL keys a few times. When your number keys display the correct characters, your keyboard is operating as it should.” here https://www.digitalocean.com/community/tutorials/how-to-use-the-digitalocean-console-to-access-your-droplet But nevertheless it’s kinda awkward and they must fix their console app IMO.

Same problem here. First I started getting “ssh: connect to host x.x.x.x port 22: Connection refused” then trying to login using their console I am getting “login incorrect”. I also tried to reset password several times and still no luck with logging in.

I too have had the same problem, I spent over 45 minutes trying to login and access the console. I reset my password 4 times and still no access. it keep saying incorrect login. Finally when I managed to login, it asks to change password and asks for my current password again, even before I could finish re-entering the current password, it kicks me out! Digital Ocean’s console access is simply very inconvenient and archaic. Digital Ocean claims simplicity and ease of use of their server. Whats the point if one cant even access their console? The console obviously does not have copy and paste for password. And one cannot easily remember the jargon 16 character temp password. I just read this post that I have to use ssh access… I did not know what it was. Only to find that I have to download another program called putty to access the console for the first time…Now why dont they tell people these information right up front? by the console access icon? Why dont they use inputboxes for simply login and access? up to now, I have not been able to login. 3 more attempts at this stupidity and I am going to cancel the account.

Hii all, I am new to digital ocean, last week i created a new droplet, it works fine for 5 days and after that when i do ssh, connection timed out error occurs, when i access through console, i got an error that server disconnected code:1006, shall i know what is the problem?? please reply me asap…


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Having the same issue. It’s ridiculous, cancelling my subscription

when prompted for

(current) UNIX PASSWORD

enter the password you received on mail. After that, you will be asked to enter your new password

The same thing was happening to me - it kept disconnecting while I was typing the password. I found a (really stupid) way to solve it: (& yes, I know point 3 goes against everything we are taught about setting passwords but it was the only way I could make it work. I think the password can be reset again later after being logged in when it can be done slower)

  1. write the password sent by the welcome email on a post-it note & stick it so it can be read without moving eyes from keyboard
  2. practice typing it many times in a text document until it can be typed with no pauses between pressing keys
  3. pre-prepare a new password - make it VERY simple (preferably one you already use that your fingers can type fast without pausing)
  4. Take a big breath & start the console. enter the login name (root), hit enter, then type the password really fast without pausing & hit enter again
  5. without pausing (not even to breath again) type the new password, hit enter then type it again & hit enter all without any pauses

this worked for me - I know it sounds stupid but by going really fast & not even pausing long enough to move my eyes to the screen I got it to reset the password & login. Then I logged in again in the normal leisurely way & had a look around the directory structure slowly without being kicked out.

hope this helps someone else!

Here’s what worked for me to fix this issue:

  1. Click on ‘droplets’ on the far left side of digital ocean menu page. Click on the correct droplet and then hit ‘access’ on the left-hand sub-menu that appears. Reset root password, and stay on this page.
  2. Once digital ocean has emailed you a new password, click “launch console” from the same page that you reset your password on (At least for me, my local terminal wouldn’t work here at first). Type ‘root’ for login, and copy paste the password in. Don’t try to type it, the terminal has shift key issues. Hit enter.
  3. It will prompt you to set a new password, but you need to copy and paste your 'current" (post-first reset) password again to verify, and then you can pick a new one.
  4. After the second password reset was confirmed, I could SSH in with my local terminal by typing ssh root@[my ip address here], and using the password I picked myself. Good luck!

Make sure you are using the username root and not the one you use to access your account. Took me a while to figure this out :/

If you type directly into the console, it may initially read your number keys incorrectly, as if the SHIFT key is pressed. For example, pressing the 2 key may enter @.

This happens only when typing. You can avoid the problem by copying the text, then pasting it into the console by pressing CTRL + v. You can also reset this behavior and ensure that your key strokes are being received correctly by pressing SHIFT and CTRL a few times, then testing your number keys again.

deleting my account. your services are horrible

i can’t log in, i have spent the last 3 hours trying and resetting my password. WTF

This is the second time my login passwords are lost, root and my user with sudo, I can login the user via ssh and unable to sudo, how is that possible? Are this droplets so weak and buggy?

When I created my droplet I associated my SSHKEY. I am facing the same problem, not sure how to resolve this, almost wasted 4 hrs on googling and trying different options.