Question

Problem With OpenVpn in DigitalOcean droplets ( ports are closed ? )

Hello ,

I tried New York droplet( its not NY its NJ I don’t know why ? ) , Germany , Netherland and San Francisco Droplets To install OpenVpn on them.

I also tried OpenVpn Access Server From DO marketplace , but none of them works and it seems ports are blocked ?

only San Francisco is functioning.

iptables are set and OpenVpn is working fine in other VPS from other providers so im sure settings are ok.

anything I should do in DO that I don’t know ?

thanks for help <3


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@alexdo

Hello , Thanks for Reply.

Yes I followed that instruction too ( using its ufw part ).

I’m using a script to install OpenVpn server and this script is configuring all I need.

Here is the link : https://github.com/angristan/openvpn-install

I also tried OpenVpn Access Server from DO MarketPlace but I cant reach its admin panel. It seems ports are blocked ?

Just San Francisco droplet is functioning ( both script and Access Server from DO MarketPlace ) .

Eyy Milad Abedi,

In addition to @alexdo says…

DigitalOcean will grey out any regions that are not available to your chosen Droplet plan. Some are disabled due to limited capacity if you don’t already have resources in that region. DigitalOcean attempts to select the best option for you, but you can select a specific one.

Regards, Sergio Turpín

Hello there,

Can you share more information about the issue you’re having with the configuration? You can use UFW to allow incoming traffic to your OpenVPN droplet and also set different rules to match your needs.

Also, have you completed the installation following our tutorial here:

https://www.digitalocean.com/community/tutorials/how-to-set-up-and-configure-an-openvpn-server-on-ubuntu-20-04

Regards