Problem with pages loading very slow...

August 22, 2014 1.7k views

1GB ram, LAMP, just one wordpress site using classipress theme with over 30k ads and lot of content, with mysql db 500+ mb large, always about 15-30 visitors on site at every moment (looking at google analitics live preview), sometimes more.

Now, website is working, but pages are loading slow, sometimes very fast, and other times it takes 20+ seconds to open a page, and sometimes a blank page is open.

I run free -m when page is loading slow and get something like this:

total used free shared buffers cached
Mem: 1001 919 82 21 42 553
-/+ buffers/cache: 323 678
Swap: 1023 31 992

if I understand right, this means I have 678 mb free. Then what is the problem why are pages loading so slow most of the times ?

Some of the settings I have:

keep alive - OFF

<IfModule mpm_prefork_module>
StartServers 2
MinSpareServers 2
MaxSpareServers 5
MaxRequestWorkers 10
MaxRequestsPerChild 0

in my.cnf

keybuffer = 64M
allowedpacket = 1M
stack = 64K
threadcachesize = 8
myisam-recover = BACKUP
tablecache = 8
cachelimit = 1M
cache_size = 16M

in error.log i have errors like

Maximum execution time of 30 seconds exceeded in.... and sometimes pages open blank, nothing there...

and also

server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting, but I tried that and it did not worked.

Any help would be appreciated!

2 Answers

You should turn on keep alive.

Your database is quite big consider using cache plugin to your wordpress.

You should also considering separate web and database. order 2 x 512MB droplet then put your web in droplet A then database in droplet B.

Have another answer? Share your knowledge.