Problem with php when installing vesta panel

November 28, 2015 1.7k views
PHP MySQL Debian

Hello, I've been trying to install vestacp the day, and I always have this problem:

$cfg['Servers'][$i]['pmadb'] ... OK
$cfg['Servers'][$i]['relation'] ... não está OK [ Documentação ]
Recursos de relações gerais: Desabilitado

$cfg['Servers'][$i]['table_info'] ... não está OK [ Documentação ]
Exibir recursos: Desabilitado

$cfg['Servers'][$i]['tablecoords'] ... não está OK [ Documentação ]
$cfg['Servers'][$i]['pdf
pages'] ... não está OK [ Documentação ]
Criação de PDFs: Desabilitado

$cfg['Servers'][$i]['column_info'] ... não está OK [ Documentação ]
Exibindo comentários da coluna: Desabilitado
Transformações do navegador: Desabilitado

$cfg['Servers'][$i]['bookmarktable'] ... não está OK [ Documentação ]
Consulta SQL gravada: Desabilitado

$cfg['Servers'][$i]['history'] ... não está OK [ Documentação ]
Histórico SQL: Desabilitado

$cfg['Servers'][$i]['designer_coords'] ... não está OK [ Documentação ]
Designer: Desabilitado

$cfg['Servers'][$i]['tracking'] ... não está OK [ Documentação ]
Tracking: Desabilitado

$cfg['Servers'][$i]['userconfig'] ... não está OK [ Documentação ]
User preferences: Desabilitado

Does anyone know how I can solve this problem?

3 comments
  • If you could provide things in English, I could help. The most I can make out of this is that it is a phpMyAdmin configuration.

  • Ok friend, following in English, thanks.

    $ cfg ['Servers'] [$ i] ['pmadb'] ... OK
    $ cfg ['Servers'] [$ i] ['relation'] ... is not OK [Documentation]
    Resource general relations: Disabled

    $ cfg ['Servers'] [$ i] ['table_info'] ... is not OK [Documentation]
    Display features: Disabled

    $ cfg ['Servers'] [$ i] ['tablecoords'] ... is not OK [Documentation]
    $ cfg ['Servers'] [$ i] ['pdfpages'] ... is not OK [Documentation]
    Creating PDFs: Disabled

    $ cfg ['Servers'] [$ i] ['column_info'] ... is not OK [Documentation]
    Showing comments column: Disabled
    Browser transformations: Disabled

    $ cfg ['Servers'] [$ i] ['bookmarktable'] ... is not OK [Documentation]
    SQL query written: Disabled

    $ cfg ['Servers'] [$ i] ['history'] ... is not OK [Documentation]
    SQL History: Disabled

    $ cfg ['Servers'] [$ i] ['designer_coords'] ... is not OK [Documentation]
    Information: Disabled

    $ cfg ['Servers'] [$ i] ['tracking'] ... is not OK [Documentation]
    Tracking: Disabled

    $ cfg ['Servers'] [$ i] ['userconfig'] ... is not OK [Documentation]
    User preferences: Disabled

  • @alexandrepjh Awesome thanks! Writing an answer now :)

3 Answers

@Zachary_DuBois - phpMyAdmin always has to be the one script that has the most complicated and well...over-complicated configuration setup. I really wish they'd revamp the project and slim things down. It's configuration like this that makes it a nightmare :-).

@alexandrepjh

First, for simplicity, I would recommend Adminer over phpMyAdmin. It's slimmer, a single file (over hundreds) and IMO, much faster while providing the same options. If you find that something isn't there that you need, look at the available plugins.

All you need to do with Adminer is download the file, upload it to your web server and access it (i.e. there is no installation process). You'll then enter in your hostname, database name and database password and click login. Simple and easy.

Of course, you do want to restrict access to this file and I would also rename it something obscure (i.e. not adminer.php) as scanners are run and that file name is commonly included in such scanners (which are run by hackers looking to break in to your DB).

So what it looks like is you never added a user/database for phpMyAdmin to use. When you install phpMyAdmin, there is a file in the directory sql called create_tables.sql. You want to create an empty database for phpMyAdmin. Then import that sql file using cat /path/to/create_tables.sql | mysql -u <mysql user> -p <database> or you can upload it through phpMyAdmin assuming you can login with a user that can create/edit databases.

After doing that, you'll want to create a phpMyAdmin user in your database instance. Make sure to only give this user permissions on the phpMyAdmin database you created. After, edit your phpMyAdmin config.inc.php with the following:

$cfg['Servers'][$i]['pmadb'] = 'phpMyAdmin DB name';
$cfg['Servers'][$i]['controlhost'] = '<DB Hostname/IP>';
$cfg['Servers'][$i]['controlport'] = '3306';
$cfg['Servers'][$i]['controluser'] = '<phpMyAdmin User>';
$cfg['Servers'][$i]['controlpass'] = '<DB Password>';

And you should be good. @jtittle has a good find too so take a look at his answer. I am taking a look at that right now :)

Hello, thanks for the help, then I searched in all directories and not found the create_tables.sql file.
I have no idea how to do this, I had already installed the OS and various vestacp before and never had this problem, but now all that I try to install OS have this problem.

Have another answer? Share your knowledge.