Question

Problem with second SSH key in droplet

  • Posted April 23, 2014

Hello,

I manually added my public ssh key to the authorized keys file on my droplet, but i am not sure exactly how i can access the server from my local shell as it keeps prompting me to enter a password when i try to ssh root@<ip.address> . I have reloaded the ssh and rebooted the droplet; any advice would be appreciated!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

No problem! Just glad you got it working.

wow yup i typed it wrong, as i was waiting for a response i went over it again and 1 character was not capitalized; I’m finally into the server from my local machine. While i do not believe my problems are over concerning launching my site; 1 large hurdle has been overcome. I can offer nothing but the deepest gratitude for you’re help Andrew, thanks for looking out for the new guys!

Are you positive that you typed in the ssh key correctly? The server checks the key and then rejects it before moving onto asking for a password. <br> <br>I can’t help but notice that you seem to have another ssh key for GitHub. There is a handy command named “ssh-import-id” that can import the public ssh key for a user from GitHub. <br> <br><pre> <br>ssh-import-id gh:$(github_username) <br></pre> <br> <br>That might be the quickest solution for you.

Heres what i got from the debug, thanks so much for that useful command! <br> <br>debug1: Authentications that can continue: publickey,password <br>debug1: Next authentication method: publickey <br>debug1: Offering RSA public key: /Users/coreykepple/.ssh/id_rsa <br>debug1: Authentications that can continue: publickey,password <br>debug1: Offering RSA public key: /Users/coreykepple/.ssh/github_rsa <br>debug1: Authentications that can continue: publickey,password <br>debug1: Trying private key: /Users/coreykepple/.ssh/id_dsa <br>debug1: Next authentication method: password

Try running it with the “-v” flag: <br> <br><pre> <br>ssh -v root@your.ip.address <br></pre> <br> <br>It should provide some information that might help figure out what is going on here. Could you paste the part that beginning with something like: <br> <br><pre> <br>debug1: Authentications that can continue: publickey,password <br></pre>