Question

problem with short_open_tag in server

hello

i tried all the way to make short_open_tag = on and staying off

i check it from phpinfo its keep saying off

i changed from /etc/php5/apache2/php.ini and from /etc/php5/cli/php.ini

and nothing happen

Subscribe
Share

yea i using PHP5 over Apache2 but i don’t know what mod .

yea i restarted apache after the changes .

Are you using PHP5 over Apache2? (mod_php5) Are you using PHP-FPM or any other? => This would require to take the changes into another file.


And it’s

short_open_tag=On

for the php.ini - File

Have you restarted apache after the changes?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Alright, have you tried to create a phpinfo - File

phpinfo.php:

<?php
phpinfo();
?>

Do you see the setting in there enabled or disabled? Do you have anything special in your vHost Config. (Apache)?


Maby the option short_open_tag is twice in your config, or in an imported configuaration.

And it’s

short_open_tag=on

for the php.ini - File

Have you restarted apache after the changes?

# service apache2 restart
or
# service httpd restart