Problem with Wordpress updater and Jetpack connection (register_http_request_failed)

October 17, 2014 3.2k views

Three days ago I uploaded new version of my blog, and when I was activate Jetpack plugin on Wordpress API, I always receive a message about http_headers. Below, the message that I'm getting:

Jetpack could not contact register_http_request_failed. This usually means something is incorrectly configured on your web host.
name lookup timed out

I don't change any configurations in my droplet, iptables or file permissions....yesterday (10/16/2014) I received a mail from Digital Ocean talking about SSL v3, and I think this can be the root of problem (or not).

Is there any change or lock on datacenter that could block Wordpress authentication with Wordpress API ?

More info

-Admin interface is so slow because wordpress always checks for updates of his core (5-10 seconds to get response for a request avg).

3 Answers

I found the problem on my DNS config. Here (in Brazil) we always use Google's DNS ( or, my droplet has these ones on resolv.conf.

I looking for NY public DNS and replaced current DNSs by this new one (

My /etc/resolv.conf:



All internal requests from Wordpress are working perfectly.

  • I'll verify that this works. Thanks for the leg work carlos.spohr!

    I don’t remember specifically setting google nameservers in my resolv.conf file so perhaps it’s a default somehow? I'd be interested in knowing.

    I'm very inexperienced at server admin and I followed guides here on DO to set up my Ubuntu server. Couldn't find a step setting up resolv.conf.

    In any case, thanks again.

I just found this answer (read the comment to the answer by davidkomer).

Only having one nameserver in resolv.conf fixed it.

I removed and all seems copacetic. In case one wants to continue using Google DNS.

  • Hi @st8ofmindz79,

    Always is a good idea have more than one nameserver. Here in Brazil, sometimes the main DNS go down :/, bacause this, here a lot of people use Google's DNS.

    Is your problem also solved with my solution ? ..anything I can try to help you with it.

    att. carlos.spohr

  • Good point!
    Interestingly enough it's nameserver which seems to be the culprit.
    When that is first in the list the request fails but if it's second after everything is good (obviously because it never gets to it).

    I removed and replaced it with the one you listed as those both seem to work.



Have another answer? Share your knowledge.