Question

Problems installing Nginx on Ubuntu 18.04

Is seems that I having issues with the step 5. The server fails to restart after sudo nginx -t . https://www.digitalocean.com/community/tutorials/how-to-install-nginx-on-ubuntu-18-04#step-5-setting-up-server-blocks-(recommended)

I tried reinstalling NGINX without completing “Step 5 – Setting Up Server Blocks (Recommended)”. I just copy pass my entire web server files in the HTML directory and it works just fine. Is Step 5 really necessary? Is their a better way than Step 5 because obviously this step is buggy and untested?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks for the reply! I managed to get it to work earlier. It was some typos I missed in the config file plus files aren’t in the correct location. Nginx won’t work if you didn’t follow the correct syntax.

Hello, @SephiaSky

I’ve followed the tutorial on a fresh droplet and everything went all good without any issues. Do you get any syntax errors when you check the Nginx configuration using the command you’ve mentioned:

sudo nginx -t

You can skip the part with the creation of the site’s files, e.g the HTML file for the index page and go and setup directly the server block:

/etc/nginx/sites-available/example.com

server {
        listen 80;
        listen [::]:80;

        root /var/www/example.com/html;
        index index.html index.htm index.nginx-debian.html;

        server_name example.com www.example.com;

        location / {
                try_files $uri $uri/ =404;
        }
}

then enable the file by creating the symlink

sudo ln -s /etc/nginx/sites-available/example.com /etc/nginx/sites-enabled/

and then tweaking the nginx config file:

/etc/nginx/nginx.conf

Let me know if you have any questions.

Regards, Alex