Question

Problems with logging into droplet

Posted October 25, 2021 62 views
Ubuntu

I have a few problems with my droplet, that basically make it impossible for me to log in.

First I wanted to connect with putty from new machine, I changed public/private keys on digitalocean, made them with putty key generator.

When I try to connect via putty to droplet, I got error that server refused my key, I tried few times with new key pairs but still the same error.

I tried to log in from droplet console, it isn’t working as well, it says: “all configured authentication methods failed”, tried with recovery console, got connected but I forgot my root password so I reseted it and used password in email to make a new one, but I can’t log in with new one (tried twice as well).

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hello,

Usually, when you add a new SSH key via your DigitalOcean control panel, it is going to be available for new Droplets only, the key does not get added to the existing Droplets.

Regarding the root password, I could suggest trying to type it out rather than pasting it to make sure that it does not get cut.

Once you have access to the recovery console you could follow the steps here on how to recover from a lost SSH key so you could add your new key to your existing Droplet:

https://docs.digitalocean.com/products/droplets/resources/lost-ssh-key/

If the root password is still not working, I would recommend getting in touch with the DigitalOcean support team.

https://www.digitalocean.com/support/

Hope that helps!
- Bobby.