Problems with Nginx when attempting to install other packages

February 20, 2017 192 views
Linux Basics Nginx Ubuntu 16.04

there are certain applications that I try to install on my ubuntu server and I keep running into to nginx issues like this.

I want to fix this. I'm just started to use nginx so I'm new to this.

Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nginx, action "start" failed.
dpkg: error processing package nginx-core (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of nginx:
 nginx depends on nginx-core (>= 1.10.0-0ubuntu0.16.04.4) | nginx-full (>= 1.10.0-0ubuntu0.16.04.4) | nginx-light (>= 1.10.0-0ubuntu0.16.04.4) | nginx-extras (>= 1.10.0-0ubuntu0.16.04.4); however:
  Package nginx-core is not configured yet.
  Package nginx-full is not installed.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.
 nginx depends on nginx-core (<< 1.10.0-0ubuntu0.16.04.4.1~) | nginx-full (<< 1.10.0-0ubuntu0.16.04.4.1~) | nginx-light (<< 1.10.0-0ubuntu0.16.04.4.1~) | nginx-extras (<< 1.10.0-0ubuntu0.16.04.4.1~); however:
  Package nginx-core is not configured yet.
  Package nginx-full is not installed.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.

dpkg: error processing packagNo apport report written because the error message indicates its a followup error from a previous failure.
e nginx (--configure):
 dependency problems - leaving unconfigured
Setting up clamav-base (0.99.2+dfsg-0ubuntu0.16.04.1) ...
/etc/mail/aliases: 2 aliases, longest 4 bytes, 24 bytes total
Setting up libllvm3.6v5:amd64 (1:3.6.2-3ubuntu2) ...
Setting up libclamav7 (0.99.2+dfsg-0ubuntu0.16.04.1) ...
Setting up clamav-freshclam (0.99.2+dfsg-0ubuntu0.16.04.1) ...
Setting up clamav (0.99.2+dfsg-0ubuntu0.16.04.1) ...
Setting up clamav-daemon (0.99.2+dfsg-0ubuntu0.16.04.1) ...
Setting up clamdscan (0.99.2+dfsg-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Processing triggers for systemd (229-4ubuntu13) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 nginx-core
 nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)

Here is the results of "systemctl status nginx.service"

nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2017-02-15 15:17:27 UTC; 1min 40s ago

Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to 0.0.0.0:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:27 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to 0.0.0.0:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:27 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:27 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] still could not bind()
Feb 15 15:17:27 wordpress-2gb-nyc3-01 systemd[1]: nginx.service: Control process exited, code=exited status=1
Feb 15 15:17:27 wordpress-2gb-nyc3-01 systemd[1]: Failed to start A high performance web server and a reverse proxy server.
Feb 15 15:17:27 wordpress-2gb-nyc3-01 systemd[1]: nginx.service: Unit entered failed state.
Feb 15 15:17:27 wordpress-2gb-nyc3-01 systemd[1]: nginx.service: Failed with result 'exit-code'.
2 Answers

@austinvernsonger

If you take a look at:

Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to 0.0.0.0:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:26 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:27 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to 0.0.0.0:80, backlog 511 failed (98: Address already in use)
Feb 15 15:17:27 wordpress-2gb-nyc3-01 nginx[18334]: nginx: [emerg] listen() to [::]:80, backlog 511 failed (98: Address already in use)

This is telling you that NGINX is unable to bind to Port 80 (IPv4 and IPv6) on 0.0.0.0 because it's already listening.

Are you by chance using 0.0.0.0:80 for the listen directive inside your server blocks?

i.e.

server {
    listen 0.0.0.0:80;
}

If so, this should be:

server {
    listen 80;
}

If the above is true, this needs to be changed on all server blocks. If not, please post your server blocks and I can take a look at them for you.

Where do I fix that at?

Have another answer? Share your knowledge.