Problems with root password and recovery

September 10, 2015 2.9k views

Hi guys

I'm a novice and my situation is as follows;

  • Droplet been running fine for weeks.
  • Dev team building new system for me.
  • This morning Dev team cant access site
  • Log ticket with DO
  • Response is droplet pinging so seems ports 22 and 80 are closed now (we have no idea how this happened)
  • Support advises to login to console.
  • Root password not being accepted in console.
  • Reset root 3 times - still no accesss
  • Support advise to manually change it via recovery. I set the password myself manually.
  • Back to console - new password doesnt work
  • Reset password via normal dashboard method again.
  • Still cant access console

So basically they are now telling me:

""We're really sorry about the trouble you're having signing in to your Droplet. Unfortunately, we cant identify anything which would prevent login through the Console using the password as reset from the recovery ISO unless something was wrong with the operating system on the Droplet itself. As a result, the only other solution we have would be to start the Droplet from the recovery image again, and copy any needed files off the Droplet and onto a new one. Other than that, we don't have access to your Droplet and would not be able to diagnose the specific internal issue leading to this. ""

So I tried once more to mount the recovery myself and when i booted it up I see only this in console.

I am at my wits end.
The DO password reset doesnt allow me to access the console.
I cant get onto the server via SSH because the port 22 is closed.

I need help. Willing to pay someone to help me.

Thanks - Allan

2 Answers

I a sorry for the trouble you've encountered and the confusion. The recovery option in the control panel is a recovery kernel which can be used for a filesystem check. The recovery ISO that our support team member recommended can be set as the boot device for your droplet only by a support team member. Please reply to the ticket and they will mount the image allowing your droplet to boot from it.

  • Why would the standard password reset not work as a password for the console?
    This is my main concern. I am a novice and I do not know how to actually use the recovery ISO myself. Is there anyway I can get some assistance from someone to help me get into my server so we can open the ports so we can SSH into the actual machine??

    • Without seeing things first-hand I cannot say why the password reset would fail to work. One possibility is that if the shell for your root user were set incorrectly it may appear that the password is failing to be accepted since the session would end immediately and the login prompt would return.

      The recovery ISO provides a menu based system in the console where you can mount your droplet's disk image and enable an SSH (and SFTP) service (in the recovery environment) in order to allow remote access and investigate the issue.

      • Okay thanks that makes sense. So when I enable SSH it will provide me with a temporary SSH password correct? And then we can access the server via SFTP and SSH and do the necessary IPtable fixes to get the ports open?

        Is that right?
        I've asked them on the ticket now to reload the ISO. I am still waiting for a response........

        • The recovery ISO will give you a temporary password to use for it's ssh/sftp service. This service is being run from the recovery environment however and not from your droplet's filesystem. Your filesystem can be mounted from the same menu and will be available remotely. This will provide you with full access but will not resolve the underlying issue with your root password.

          The recovery ISO has an option to reset the root password inside your droplet's filesystem. It sounds like you may have already done this but I would recommend doing it again and then checking that a valid shell is set in your /etc/passwd file.

          It is also possible, once your filesystem is mounted, to chroot into your droplet's disk image from the recovery environment. Assuming your filesystem is mounted at /mnt in the recovery environment this command will work:

          chroot /mnt /bin/bash

          Once you are chrooted into your filesystem you can also use the adduser/useradd tools to create a new user account or take other steps to investigate the issue.

          • Thanks so much in advance Ryan


          • Allan, I can't take any payment but I would be happy to take over your ticket from our support team and can at least log in and take a look for you.

            I'll follow up with you in the ticket you have open.

Have another answer? Share your knowledge.