ProFTPd Configuration & Login via FTP (failed)!

July 10, 2014 3.4k views


I have deployed Ubuntu 14.04 droplet and installed ProFTPd. I followed this guide and tried logging in with my credentials. All seems to go well till FileZilla says: 227 Entering Passive Mode (IP address) .. MLSD ....: Then the connection times out. Tried to login a few times but cant get-in. Seems like I'm missing some configuration but don't know what!

Can anyone help?


4 Answers

It looks like there's a firewall blocking Passive connections. Try using Active mode instead, does that work? Are you using UFW or just plain IPTables?

Hi Kamal,

Yes I was using UFW and trying to login through FileZilla. I don't know how to us active mode :( Although I had UFW installed but allowed FTP Port. (ufw allow 21/tcp)

Now I tried fresh install without installing UFW but even now it is not working. However, now the error has changed to "530 Login Incorrect". I'm using correct password. I included my user into proftpd.conf and the group as well. But not working!


  • Check ProFTPd's error log for more details on the 530 error:

    sudo tail /var/log/proftpd/proftpd.log

    Try allowing access to port 20 and configuring FileZilla to use active mode: How to set active mode in filezilla (while the video is old, it's still the same method).

Hi Kamal

I checked the log and it seems no shell was defined for the ftpuser. I tried adding the user to /bin/bash (I'm not sure if this is the correct entry) but even now I'm not able to login.

As there is no Firewall installed to there is nothing to allow. I tried active mode but couldn't succeed. After adding shell (bash) I could go till "200 MLSD" where it times out.

What next is to be checked? Should I post my proftpd conf file here?


I changed some other settings (added directory syntax in proftpd.conf). Now I'm not getting any MLSD error but now my directory listing fails. See what FTP says:

Command: USER ftpadmin
Response: 331 Password required for ftpadmin
Command: PASS ********
Response: 230 User ftpadmin logged in
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Features:
Response: SITE UTIME
Response: MDTM
Response: SITE RMDIR
Response: TVFS
Response: SITE COPY
Response: MFMT
Response: SIZE
Response: LANG en-US.UTF-8;en-US*
Response: SITE MKDIR
Response: MFF modify;;UNIX.mode;
Response: MLST modify;perm;size;type;unique;;UNIX.mode;UNIX.owner;
Response: UTF8
Response: EPRT
Response: EPSV
Response: 211 End
Command: OPTS UTF8 ON
Response: 200 UTF8 set to on
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is the current directory
Command: TYPE I
Response: 200 Type set to I
Command: PORT 59,180,165,211,26,61
Response: 500 Illegal PORT command
Error: Failed to retrieve directory listing

Have another answer? Share your knowledge.