Question

proftpd - refusing connections?

  • Posted August 7, 2013

Hi,

I installed wordpress using the following directions:

https://www.digitalocean.com/community/articles/one-click-install-wordpress-on-ubuntu-12-10-with-digitalocean

I got all the way though and am now trying to login by FTP. I completed the FTP install section as given and am now getting the following message when I try to login:

Connection refused

I tried with various clients, including ftp through my mac (terminal) - same response.

One thing I did do was install memcached - not sure whether that’s related in any way.

I also restarted the server.

Subscribe
Share

This comment has been deleted


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Is ProFTPd running? <br> <br><pre>service proftpd start <br>netstat -plutn | grep :21</pre>

Got a similar problem here and figured it out this way :

Check in your /var/log/proftpd/proftpd.log.1 or /var/log/proftpd/proftpd.log If you’ve got this message : ProFTPD killed (signal 15) You have the same problem… ProFTPD seems to fail restart on log rotate (I got no explaination on this).

Fix is here or here

Hope it’ll help.

@amkause: What’s the output of this command? <br> <br><pre>proftpd --configtest</pre>

Hi Kamal, <br> <br>I have the same problem, my FTP Service will not start: <br> <br>[root@hosting init.d]# service proftpd start <br>Starting proftpd: [FAILED] <br> <br>[root@hosting init.d]# sudo /etc/init.d/proftpd check-config <br>Usage: proftpd {start|stop|restart|try-restart|reload|status} <br>

Edit <code>/etc/proftpd/modules.conf</code> and comment <code>LoadModule mod_tls_memcache.c</code> out. Restart ProFTPd, does it work now?

hmm…I had a feeling that it was related to memcached… <br> <br>root@aaaaa:~# sudo /etc/init.d/proftpd check-config <br>aaaaa proftpd[1408]: mod_tls/2.4.3: compiled using OpenSSL version ‘OpenSSL 1.0.1 14 Mar 2012’ headers, but linked to OpenSSL version ‘OpenSSL 1.0.1c 10 May 2012’ library <br>aaaaa proftpd[1408]: mod_sftp/0.9.8: compiled using OpenSSL version ‘OpenSSL 1.0.1 14 Mar 2012’ headers, but linked to OpenSSL version ‘OpenSSL 1.0.1c 10 May 2012’ library <br>aaaaa proftpd[1408]: mod_tls_memcache/0.1: notice: unable to register ‘memcache’ SSL session cache: Memcache support not enable <br> <br>Your second command produced output that included both openssl and memcache… <br> <br>root@aaaaa:~# sudo /etc/init.d/proftpd force-start <br> * Starting ftp server proftpd aaaaa proftpd[1427]: mod_tls/2.4.3: compiled using OpenSSL version ‘OpenSSL 1.0.1 14 Mar 2012’ headers, but linked to OpenSSL version ‘OpenSSL 1.0.1c 10 May 2012’ library <br>aaaaa proftpd[1427]: mod_sftp/0.9.8: compiled using OpenSSL version ‘OpenSSL 1.0.1 14 Mar 2012’ headers, but linked to OpenSSL version ‘OpenSSL 1.0.1c 10 May 2012’ library <br>aaaaa proftpd[1427]: mod_tls_memcache/0.1: notice: unable to register ‘memcache’ SSL session cache: Memcache support not enabled <br>aaaaa proftpd[1427] 192.254.189.222: fatal: Socket operation on non-socket <br> <br>Note that I replaced my hostname with aaaaa (the name is a little nsfw) <br>

What’s the output of these commands: <br> <br><pre>sudo /etc/init.d/proftpd check-config <br>sudo /etc/init.d/proftpd force-start</pre>

Thanks Kamal - <br> <br>I get the following message to the first command: <br> <br>ProFTPD warning: cannot start neither in standalone nor in inetd/xinetd mode. Check your configuration. <br> <br>The second command does not produce any output. I tried netstat without grep and see apache2, sshd, sendmail and mysqld listening on various ports