Question

Proftpd won't says I'm using the wrong login for FTP connection

I have a droplet, and I have a registered domain name that I transferred the DNS to digital ocean. All that appears to by okay.

I can log in to digitalocean, and I can log into my Ubuntu control panel using root as a username and a separately created password.

I’ve installed the proftpd file transfer program and reset the conf file using my registered domain name uncommented the default user according to instructions.

Now when I open a browser and for to ftp://mydomainname.com I get a login screen from the proftpd program. I’ve tried entering my digitalocean password and my Ubuntu username “root” and password but the proftpd login screen is telling my that my authentication has failed.

What do I need to do, please.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

That did it!

Thanks so much.

Hi!

FTP is an inherently insecure protocol. By default, unless FTPS is implemented, all credentials are sent in plaintext over an unencrypted connection. As a result of that, almost all FTP servers block root access entirely.

I would recommend uninstall ProFTPD and connecting via SFTP, which is a completely separate file transfer protocol, that relies on SSH for authentication and encryption. You should be able to do that simply by setting your client to use SFTP and connect to port 22 and using your SSH credentials to authenticate. Here’s a tutorial on using FileZilla to transfer files via SFTP.

Alternatively, you can set up a non-root user and use it to log in via FTP. I strongly recommend against doing that.