Question

promiscuous mode SSH freeze if no activity for about 1 min

Posted July 19, 2016 3.8k views
NetworkingIPv6
Jul 19 03:56:54 App-Docker kernel: [76610.517153] docker0: port 1(veth62a1f2c) entered disabled state
Jul 19 03:56:54 App-Docker kernel: [76610.541447] docker0: port 1(veth62a1f2c) entered disabled state
Jul 19 03:56:54 App-Docker kernel: [76610.542349] device veth62a1f2c left promiscuous mode
Jul 19 03:56:54 App-Docker kernel: [76610.542357] docker0: port 1(veth62a1f2c) entered disabled state
Jul 19 03:59:00 App-Docker kernel: [76736.443964] device veth0fb9910 entered promiscuous mode
Jul 19 03:59:00 App-Docker kernel: [76736.444224] IPv6: ADDRCONF(NETDEV_UP): veth0fb9910: link is not ready
Jul 19 03:59:00 App-Docker kernel: [76736.583446] IPv6: ADDRCONF(NETDEV_CHANGE): veth0fb9910: link becomes ready
Jul 19 03:59:00 App-Docker kernel: [76736.583478] docker0: port 1(veth0fb9910) entered forwarding state
Jul 19 03:59:00 App-Docker kernel: [76736.583483] docker0: port 1(veth0fb9910) entered forwarding state
Jul 19 03:59:15 App-Docker kernel: [76751.584064] docker0: port 1(veth0fb9910) entered forwarding state
Jul 19 04:02:17 App-Docker kernel: [76933.645427] docker0: port 1(veth0fb9910) entered disabled state
Jul 19 04:02:17 App-Docker kernel: [76933.669870] docker0: port 1(veth0fb9910) entered disabled state
Jul 19 04:02:17 App-Docker kernel: [76933.670768] device veth0fb9910 left promiscuous mode
Jul 19 04:02:17 App-Docker kernel: [76933.670776] docker0: port 1(veth0fb9910) entered disabled state
Jul 19 04:02:17 App-Docker kernel: [76933.683763] device veth9e31f0c entered promiscuous mode
Jul 19 04:02:17 App-Docker kernel: [76933.683869] IPv6: ADDRCONF(NETDEV_UP): veth9e31f0c: link is not ready
Jul 19 04:02:17 App-Docker kernel: [76933.683873] docker0: port 1(veth9e31f0c) entered forwarding state
Jul 19 04:02:17 App-Docker kernel: [76933.683877] docker0: port 1(veth9e31f0c) entered forwarding state
Jul 19 04:02:17 App-Docker kernel: [76933.987440] IPv6: ADDRCONF(NETDEV_CHANGE): veth9e31f0c: link becomes ready
Jul 19 04:02:32 App-Docker kernel: [76948.704082] docker0: port 1(veth9e31f0c) entered forwarding state

it seems my server run into promiscuous mode very frequently

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

There is a parameter you can set with ssh clients called KeepAliveInterval. In linux, you can edit either per account client (~/.ssh/config) or per installation (/etc/ssh/ssh_config) and set the value

Host *  ServerAliveInterval 30

This howtogeek.com link has more info. Note: not sure how to set it with other clients, like PuTTY, as I haven’t needed it.

Submit an Answer