Question

PTR record, mail servers = at lost

Posted February 25, 2014 4.2k views
I'm trying to setup postfix and devcot on centos 6. I managed to get ssl certs done, and i can send mails to others but i cant receive them. Also i changed my PTR record on droplet but my mails when somebody recive them still have cname and not A name just. I followed few articles and guides on web but well I'm not good enough to get it work well. Any help is welcome, thank you.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

5 answers
You need to perform some basic troubleshooting. No one is going to be able to assist you with such a limited amount of information, especially regarding email configuration which is complex and has a large amount of configuration options. First, check the Postfix/Dovecot log files for a hint (/var/logs/mail.log).
I think i did good config of Postfix files, cant never be sure 100% but dovecot conf files just eludes me. I think there is a problem and i cant find a solution for that.
As I said look at the logs and do some basic troubleshooting. No one is going to help you when you have provided no details. I suggest reading this article - https://library.linode.com/email/postfix/troubleshooting.
Thanks for your help, i looked over troubleshooting, and i cant find errors. Everything that says in there are fine on my side. So either some more details are wrong or something else is in question. I do require help and I'm willing to provide details if somebody wants to help. We can talk over skype or my IRC if somebody wants.
i changed my PTR record on droplet but my mails when somebody recive them still have cname and not A name just.
That's expected. The PTR record doesn't set what domain your emails appear to come from. It'll default to your mailserver's hostname. You will have to overwrite the From: header manually.
i cant receive them
What's the output of the following command?
sudo netstat -plutn
Submit an Answer