Question

Puppeteer can't handle too many request

Hi, I have implemented puppeteer on my ubuntu and it works fine. But if I tried to run multiple processes, it loads too slow, leading to an error.

This is the scenario. I open 2 droplet consoles and one on my PHP configuration, then run puppeteer, but it seems they are splitting the process/connection. Turns out the 3 processes return me an error. (can’t navigate website URL) so I’m worried now, what if there are 1000 users opening my PHP puppeteer at once?

I tried to upgrade my droplet, but the problem did not resolve.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

Have you monitored the server’s resource usage when running multiple processes? You can check if the memory or the CPU is too high which can explain the poor performance.

You can examine the server logs and check if there are any references to exhausted memory or similar errors. An additional check will be to check the web-server configuration and see if the web service can hold multiple connections without issues.

Regards