PuTTY connection refused on Windows 8.1

March 19, 2015 8.8k views
DigitalOcean Ubuntu

I installed PuTTY over a year ago on Windows 7 and frequently use it to access my droplet running Ubuntu 14.04. We are preparing to ship our belongings, and I will be staying behind to complete my work contract for a few more months. So I purchased a Windows 8.1 laptop to use in the interim. All of the tools that I need are set up on it, except that I have been banging my head against the wall for a few days now trying to get PuTTY to connect to my droplet. It appears to be installed correctly, but no matter what I do, I get a connection refused error. My poor husband is having to do all of the packing amidst all of my head-banging, and I sense that his fuse is growing short, so I thought I would ask for help.

Here are some of the things I've tried:

  • First installed PuTTY Release 0.63, then installed Release 0.64 (currently installed)
  • Made sure all settings on the Windows 8 setup match those on the Windows 7 machine
  • Generated new SSH keys and specified the Private key file for authentication under SSH Auth in PuTTY (Full disclosure: the whole SSH key stuff is somewhat fuzzy to me, but I'm leary of doing anything that might mess up the authentication that is working on my desktop since that is my only lifeline to my droplet right now.)
  • Telling Windows to allow PuTTY to pass through the firewall
  • Lots of research that turned up people saying PuTTY works just fine on Windows 8. (Note: my laptop uses an AMD processor, not Intel. Could that make a difference?)

Thank you for any pointers you can offer.


4 Answers

I can confirm that Putty works just fine with Windows 8.1
Also MTPutty works just fine.
Connection refused is basicly something at the server end.
Are you sure you're trying to SSH into the correct IP and the correct port?

Try Bitvise SSH, putty is awful and useless

Thank you for your responses. Yes, sollidius. I made sure that every entry was exactly the same as the connection on my desktop machine (and have checked and double-checked every setting). I've found dozens of posts from people saying it works just fine with Windows 8.1. That's why I'm so baffled.

It does seem to be the server doesn't like something that is being passed to it when I try to connect, but it likes what it's getting from my desktop. I did create a new private key on the laptop and specified the file name in the SSH Auth setting. Is there something I need to do on the server side to make it recognize that key?

Which processor does your machine use? I'm only asking because the download said it was for Intel, and my laptop has an AMD processor.

EpicCDN, I appreciate your sentiment, but I'm concerned that whatever is causing the connection to be rejected would probably still be there. If I don't get it figured out by this weekend, I'll look into using Bitvise SSH.


Thanks again for your responses. It's working now. In case others run into this, I had to:

  • Add the public key generated on the laptop to my file (adding 'ssh-rsa before it and myusername@mydomain' at the end and removing all newline characters)
  • Find a port that was actually listening and specify that port for the putty session (thanks, sollidius!)

Seems so simple now! My husband will be pleased that I can get back to helping him pack and that we can finally pack my desktop.


Have another answer? Share your knowledge.