Putty error: No supported authentication methods available (server sent: publickey)

Posted June 17, 2017 309.1k views
NginxUbuntuLEMPUbuntu 16.04

I am trying to setup a server for my wordpress site. I was going through this tutorial ( to setup ssh keys.
After step five when it says to try logging in with the ssh keys with the newly created user putty returns back with a error saying: “No supported authentication methods available (server sent: publickey)”
I put the public key in the authorized_keys file and everything the tutorial said but it still returns that error. If I try logging in to root with the same private key it works fine. It just shows that error when I try logging in with the new user.

Any help would be appreciated.

  • I would also like to mention, I made the keys with Puttygen and I added the public key to digitalocean. I used the key when creating the droplet.

  • I guess you have loaded the .pem file first and then generated the Public key and private key by randomness.

    But if you generate key-pair by randomness and them upload .pem file to generate Public and private key pair then you won’t get this error.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

6 answers

I also had this problem, login from putty as root was fine but from the non-root user gave me the error above. I tried the methods given in the link but it didn’t help, eventually I managed to do it by following this guide:

This: “No supported authentication methods available (server sent: publickey)” happened to me after I turned on Microsoft One Drive backup and sync for my files including the directory where I save my ssh key. In my case the solution is simple: just go to Putty => SSH => Auth and just (re)browse again to my same key and save, then it worked. It looks backup and sync software such as Microsoft One Drive (and may be the same with Google Drive), affect the way Putty sees and identifies directories if the key directory is specified then later installing or turning on backup and sync including that directory.

I never got PuTTY to work, but I was able to use ssh-keygen and ssh root@IP from Git Bash.


The public key generated by puttygen cannot be used directly on Ubuntu you need to change its format as mentioned here

Hope this helps

@thelunchbawx, I am having the exact same problem. Did you figure out a solution?

In my case, I removed default login name from putty and it worked

Submit an Answer