Question about Ubuntu 12.04 HWE EOL notification

July 11, 2014 6.9k views

I have several Ubuntu 12.04LTS x64 droplets that are prompting me to install a newer HWE version or upgrade to 14.04LTS. Considering that DO manages kernel updates, does this really apply? Or do I need to take one of the recommended actions that are listed here:

3 Answers

You can upgrade to 14.04, but you don't need to. 12.04 is still supported, but you will only get security upgrades (you will not receive new software versions). You can run sudo do-release-upgrade to upgrade your droplet (make sure update-manager-core is installed: sudo apt-get install update-manager-core).

Once you've upgraded your droplet, you can power off your droplet (sudo poweroff), set your droplet's kernel to the latest 14.04 kernel, boot it up from the control panel, and run sudo apt-get install linux-image-$(uname -r) to finish installing the kernel.

  • Thanks. I have no pressing need to upgrade to 14.04 at the moment, and I'm primarily only concerned with security updates anyway, so all that's good. However, is it possible to install the 12.04.5 HWE update (Step 1 on the Ubuntu wiki page) in order to continue getting all updates? Or is that installation overridden by DO's kernel manager?

  • Installing the HWE update wouldn't affect your server as it's meant mainly for new unsupported hardware, see What is hardware enablement (HWE)?.

  • The hwe-eol notifier seems to indicate that unless I install the HWE update (which, as I understand it, doesn't apply in DO's case) or upgrade to 14.04 (which I would prefer to not do at this time), then all updates will cease, including security updates. But you mentioned that security updates will continue. Would you please clarify? Thanks.

  • Same as brian, I am understanding that all updates will stop. The message on the console says (emphasis mine):

    "Your current Hardware Enablement Stack (HWE) is going out of support
    on 08/07/14. After this date security updates for critical parts (kernel
    and graphics stack) of your system will no longer be available

Hi, my current systems need to be on 12.04. I've ran the command as follows:

sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty

I then stopped the droplet and selected a 14.04 kernel, however am still receiving the update advisory message when logging in via ssh even though a uname -r shows 3.13.0-30-generic

Wondering if all is well and the MOTD is just hanging around? Or what? Any advice appreciated.


I'm having the same problem. I'm about to open a ticket.

I had a doubt and I didn't open a ticket, instead I did a bit of digging.

To make a long story short I deleted /var/lib/update-notifier/hwe-eol to force update-motd to update the file.

  • Thanks, that worked for me, too! I initially renamed hwe-eol (to hwe-eol.disabled) just to be safe, but then I realized that hwe-eol gets recreated (with the correct announcement), so I then wiped out the old version.

Have another answer? Share your knowledge.