Question

Question on setting Digital Ocean nameservers in Route 53

  • Posted August 3, 2014

Thank you for taking the time to read this, I’ve recently decided to move from AWS over to DO and I believe I am having a bit of trouble with setting my nameservers to point to DO in route 53.

The issue that leads me to believe this is that I have set up a droplet with dokku and when I try to IP Address / specified subdomain, I get “This Webpage is not available” - preventing me from actually setting up dokku.

Right now I have a hosted zone using Amazon’s nameservers and wish to get a subdomain on Digital Ocean’s name servers. In Route 53, I added an A type Record Set pointing at my DO droplet’s IP and added an NS Record Set listing the 3 DO nameservers that were specified in my droplet.

Really not sure what else could be the issue here, any assistance is greatly appreciated.

Cheers,

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

For me, my problem was I was setting the name servers in the hosted zone, and not under the registered domain tab.

I used this guide to find the right place to set the name servers: https://docs.aws.amazon.com/Route53/latest/DeveloperGuide/domain-name-servers-glue-records.html

After this I was able to use Digital Ocean DNS.

Just came across this and followed Option A - I know this is an old post, but wanted to add that it took about 5 minutes for AWS to “catch up” and redirect traffic. I believe this was due to my “Time To Live” parameter of 300 seconds which was set in Route 53 for the rule I used. Basically, the old (AWS) IP address was cached and after the 300 seconds had passed, my new (DO) IP address was added.

@jesin I’m in the same boat as the original poster and had went with option 1 thinking this would be easy. The A record works, I got to blog.sitename.com and the wordpress-droplet loads, but in my url bar the dns entry changes to the actual IP address. I’ve since edited my apache2/sites-enabled and ensured I had the site ServerName in place. I’ve also created domain records on the GUI… Thoughts?

When you set nameservers for a subdomain it is being delegated (aka handed over) to them. So making A record changes in AWS will not make any difference.

Assuming your domain is example.com and subdomain is do1.example.com you have two options here:

Option 1:

In your AWS console create the following A record

Name: do1.example.com Type: A - IPv4 Address Value: IP.address.of.droplet

Option 2:

Create 3 NS records in AWS:

Name: do1.example.com Type: NS - Name Server Value: ns1.digitalocean.com ns2.digitalocean.com ns3.digitalocean.com

Login to your DigitalOcean account, open the DNS section, click Add Domain and fill in the details:

Name: do1.example.com IP Address: IP.address.of.droplet

Hello Brad,

you can keep your nameservers and let NS records point to AWS IPs/domains and then create A record point at your Droplet IP.

If you’d like to use DO nameservers, you can change your NS records to: ns1.digitalocean.com ns2.digitalocean.com ns3.digitalocean.com

and create domain record (equivalent to A record) in DO control panel under “DNS” menu option on left after you log in.

EDIT: Here’s some more on this topic - https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean