didit
By:
didit

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled.

October 24, 2014 3k views

I just upgrade my droplet from 512 MB RAM to 1 GB RAM.
I am using virtualmin now, when I "re-check configuration" I found this :

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled.

I tried to log in webmin -> system -> Disk Quotas -> Enable Quotas, but I found :

Failed to turn on quotas : quotaon: using //aquota.user on /dev/disk/by-label/DOROOT [/]: No such process quotaon: Quota format not supported in kernel. 

Please help me to fix this.

3 Answers

Log in to your droplet as root or as a user with sudo access and run the following commands:

sudo apt-get install linux-image-$(uname -r)
sudo poweroff

Then boot your droplet from the control panel.

  • I tried that code and I still got the same eror.
    This is the code when I type that code.

    Suggested packages:
      fdutils linux-doc-3.13.0 linux-source-3.13.0 linux-tools
      linux-headers-3.13.0-32-generic
    The following NEW packages will be installed:
      linux-image-3.13.0-32-generic
    

    But, I doubt to install them because I want to save my disk quota. Is that necessary to install that package ?

  • Yes, it's necessary to install the package in order for kernel modules (such as quota) to work. It doesn't take up much space though -- only about 41KB.

  • I just installed them, and I still got the same errors, when I logged in to webmin -> system -> Disk Quotas -> Enable Quotas.
    When I re-checked the configuration, I also still got the same errors.

Any progress with this ? I'm having the same problem running Ubuntu 16.04.1 LTS with Virtualmin.

Here is another thread that my help you solve your issue
(check the comments section - I just updated with the answer you are looking):

How To Enable User and Group Quotas

by Jan Stevens
Quotas are used to limit the amount of disk space a user or group can use on the server. There are generally two different methods of managing quotas: first, an empty file system can be created and mounted for a specific user. An advantage of this method is that no additional package is required. Second, the quota tool can be used to dynamically manage the disk quota of a user or a group. A big advantage is the possibility to change quotas on the fly without any complicated disk resizing. This guide mainly focuses on the creation of user specific quotas; however, all the commands are exactly the same for group quotas. Instead of a user name, a group name can be used in the described commands.
  • Hi,

    I used that guie, with ubuntu 16.04 in my droplet, but qhen I use quotaon this message appear:

    quotaon: using //aquota.user on /dev/vda1 [/]: No such process
    quotaon: Quota format not supported in kernel.

    Quota reports is working, but they not update the used space...plase can you help us..

Have another answer? Share your knowledge.