Question

Rebooted droplet, virtual host not being reconized

Hi there, I had a ruby on rails application running just fine on my droplet, rebooted the server with a reboot now command (in console), and now that it’s back up. It’s going to This file is located in /home/rails/app/views/home/index.html.erb, and not the virtual host path. Any help would please be apprecitated… and fast. Thanks

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This is awesome.

Basically digitalocean automigrated my droplet when they upgraded it. All my sites suddenly had the ‘Welcome to Nginx’ default message. Wtf…

Anyways, after an hour of googling and experimenting, I came upon this thread which solved everything.

My question is, why does auto-migrating a droplet make Nginx the default webserver listening on port 80??? Thats a serious fail on digitaloceans part, no?

Andrew’s response was right in my ordeal, but Kamal helped me see what was going on initially.

For those of you who get this in the future. What append was, after I rebooted the droplet, the service nginx (in my case) took over port 80, which is my default port for apache. I’ve seen posting about killing whatever service on that port to kick out whatever took your port # or to config a new port # for your vitual hosts. All it took in my case, was stopping the nginx service, and then starting up apache. BOOB… DONE. Thanks for your help everybody.

Was just looking at there, here’s what’s running

tcp 0 0 127.0.0.1:8080 0.0.0.0:* LISTEN 833/unicorn.conf -E tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 776/nginx: worker p

I stopped apache and tried to restart, now I get this

apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80