I was originally trying to have https with Positive SSL from Namecheap/Comodo.

I thought I have all the things done correctly but when I try ‘sudo service apache2 restart’, it just says [OK] but https is still not working

When I try

$ openssl x509 -in /etc/ssl/robobu.io.crt -noout -modulus | openssl sha1 openssl rsa -in /etc/ssl/robobu.io.key -noout -modulus | openssl sha1

openssl: No such file or directory
rsa: No such file or directory
-in: No such file or directory
-noout: No such file or directory
-modulus: No such file or directory
(stdin)= YYYYYYYYYYYYY

the modulus of the certificate XXXXXXXXXXXXXXX and modulus of the private key YYYYYYYYYYYYYYY do not match.

${APACHELOGDIR}/error.log

[Mon Nov 09 02:11:35.854042 2015] [mpm_prefork:notice] [pid 26088] AH00169: caught SIGTERM, shutting down
[Mon Nov 09 02:12:11.994884 2015] [ssl:emerg] [pid 26503] AH02240: Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)
[Mon Nov 09 02:12:11.994972 2015] [ssl:emerg] [pid 26503] AH02312: Fatal error initialising mod_ssl, exiting.
[Mon Nov 09 02:13:59.088969 2015] [mpm_prefork:notice] [pid 26619] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.7 OpenSSL/1.0.1f configured -- resuming normal operations
[Mon Nov 09 02:13:59.089091 2015] [core:notice] [pid 26619] AH00094: Command line: '/usr/sbin/apache2'
[Mon Nov 09 02:27:40.708424 2015] [mpm_prefork:notice] [pid 26619] AH00169: caught SIGTERM, shutting down
[Mon Nov 09 02:27:41.734314 2015] [mpm_prefork:notice] [pid 26851] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.7 OpenSSL/1.0.1f configured -- resuming normal operations
[Mon Nov 09 02:27:41.734409 2015] [core:notice] [pid 26851] AH00094: Command line: '/usr/sbin/apache2'

my apache2.conf is

ServerRoot "/etc/apache2"
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel crit
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf

******
<VirtualHost *:80>
   ServerAdmin webmaster@Robobu
   DocumentRoot /var/www
   Servername  128.199.71.225
   ServerAlias Robobu www.Robobu
</VirtualHost>

and /etc/apache2/sites-available/000-default.conf is

<VirtualHost *:80>
    ServerName robobu.io
    Redirect permanent / https://robobu.io/
</VirtualHost>
Listen 443
<VirtualHost *:443>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    ServerName robobu.io
    SSLEngine on
    SSLCertificateFile /etc/ssl/robobu.io.crt
    SSLCertificateKeyFile /etc/ssl/robobu.io.key    
    SSLCertificateChainFile /etc/ssl/robobu_io.ca-bundle
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

my server is Server version: Apache/2.4.7 (Ubuntu) and using WORDPRESS

I contacted Namecheap online chat support but the person eventually said “I can advise you to contact your hosting provider for the further investigation. It seems the errors it mod_ssl can prevent you from connecting via 443 port.”

I originally followed How To Install an SSL Certificate from a Commercial Certificate Authority and now have no idea where to fix…

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Me too, I exactly followed the “How to Install....from commercial…” am facing the same issue…were you able to find a fix?

Submit an Answer