redirect https://properorder.ie to https://properorder.com using .htaccess

July 13, 2016 816 views
Apache DNS Ubuntu

Hi,

I created the following htaccess file:

Options +FollowSymlinks 
RewriteEngine on 
RewriteCond %{HTTP_HOST} ^properorder.ie [NC] 
RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301]

https://properorder.ie & https://www.properorder.ie doesn't work, I get and SSL connetion error error, err_ssl_server_bad_format

http redirects fine.

I am obviously missing some lines of code in the .htaccess file.

Any help will be much appreciated.

Thanks,

Clive

1 comment
  • Apologies, here is the correct htaccess file:

    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    
    RewriteCond %{SERVER_PORT} 80 
    RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]
    
    # RewriteCond %{SERVER_PORT} 443
    # RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]
    
    RewriteCond %{HTTP_HOST} !^www.properorder\.co [NC]
    RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]
    
    edited by asb
1 Answer

This question was answered by @clivestrydom:

Apologies, here is the correct htaccess file:

Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{SERVER_PORT} 80 
RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]

# RewriteCond %{SERVER_PORT} 443
# RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]

RewriteCond %{HTTP_HOST} !^www.properorder\.co [NC]
RewriteRule ^(.*)$ https://www.properorder.co/$1 [L,R=301,NC]

View the original comment

Have another answer? Share your knowledge.