Question

redirecting non www to www domain

  • Posted August 6, 2013

I have co.in domain and this added in digital ocean DNS and also virtual hosts configured as below

<VirtualHost *:80> ServerAdmin webmaster@example.co.in ServerName example.co.in ServerAlias www.example.co.in

But non www is not redirecting to www domain.co.in.please let me know why this is not working. but www version is working perfectly.

my .htaccess file also given below

<IfModule mod_rewrite.c> RewriteCond %{HTTPS} !=on RewriteCond %{HTTP_HOST} !^www…+$ [NC] RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L] </IfModule>

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Run <pre>sudo nano $(ls -1d /tmp/aioefjaisjf/* | grep -v default)</pre> and set AllowOverride to All.

I have a Wordpress installation. <br>How can I configure the AllowOverride parameter?

Add <code>RewriteEngine On</code> at the top of your .htaccess file and run this command as root: <br> <br><pre>a2enmod rewrite</pre> <br> <br>Make sure you have <code>AllowOverride All</code> in your Virtualhost config. <br> <br>Finally, restart apache: <br><pre>sudo service apache2 restart</pre>