Question

redli set config keyspace

Hi there!

We are implemenitng redis database offered by Digitalocean. Currently having troubleshooting on configuring the database. We are aware that redis does not support SSL/TLS support therefore digital ocean offers us to coonect redis-daatase with redli not with redis-cli whereas redli supports connection with TLS.

Our team used some configuration for redis as follows below: config set notify-keyspace-events Ex

With redli we are not able have this feautures, indeed we should set this config. We are able to connect to database for project we should set this config, unfotunately redli does not support set this config.

What we tried: We could not connect to server where database is set. Thought may be stunnel, but not solution for this issue.

Any possibilities to connect redis database with redis-cli or any solution for setinng this conf on the server side.

Subscribe
Share

I’d love an answer to this too. I can’t migrate Kue Scheduler over to managed REDIS because of this.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

To enable config set notify-keyspace-events Ex for your database cluster, please raise a support ticket. Our support team will reach out to engineering team to enable the Redis Expiration Event.

Hope that this helps. Regards, Priyanka

This comment has been deleted