Question

Redmine and wiki on same server

Hi, I’ve got a droplet with redmine working at http://elt.kode1100.com/

I’d also like to put a wiki on the same server.

If I remove the sites-enabled/elt file which configures redmine to work in apache2 the wiki is working at http://elt.kode1100.com/wiki/

Given a sites-available/elt.kode1100.com configuration as follows.

I’ve been trying various ways to get both working at the same time but thus far unable. What do I need to adjust to share the server with redmine and the wiki. Ideally I’d like to access redmine at elt.kode1100.com/redmine

<VirtualHost *:80> ServerAdmin webmaster@localhost ServerName elt.kode1100.com ServerAlias www.elt.kode1100.com

    DocumentRoot /var/www/elt.kode1100.com/public_html
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

Thanks Alex


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Try combining both virtualhosts into one virtualhost. You can’t have two virtualhosts listening on the same domain, apache would just use one of them.

Sorry I didn’t catch that pastebin <br> <br>I’ve put the config here. <br> <br>https://sites.google.com/site/sharezbxy3/

Thanks for the help Kamal <br> <br>1. sites-enabled/elt <br> <br><VirtualHost *:80> <br> <br> ServerAdmin webmaster@elt <br> <br> DocumentRoot /home/redmine/redmine/public <br> <br> <Directory /home/redmine/redmine/public> <br> <br> RailsBaseURI /public <br> <br> Options Indexes MultiViews <br> <br> AllowOverride None <br> <br> Order allow,deny <br> <br> allow from all <br> <br> </Directory> <br> <br># ServerName www.elt.kode1100.com <br> <br># ServerAlias 37.139.1.236 elt.kode1100.com <br> <br></VirtualHost> <br> <br> <br>2. sites-available/elt.kode1100.com <br> <br> <br> <br> <br>
<br> <br><VirtualHost *:80> <br> ServerAdmin webmaster@localhost <br> ServerName elt.kode1100.com <br> ServerAlias www.elt.kode1100.com <br> <br> DocumentRoot /var/www/elt.kode1100.com/public_html <br> <Directory /> <br> Options FollowSymLinks <br> AllowOverride None <br> </Directory> <br> <Directory /var/www/> <br> Options Indexes FollowSymLinks MultiViews <br> AllowOverride None <br> Order allow,deny <br> allow from all <br> </Directory> <br> <Directory /var/www/elt.kode1100.com/public_html/wiki/images/> <br> # Ignore .htaccess files <br> AllowOverride None <br> <br> # Serve HTML as plaintext, don’t execute SHTML <br> AddType text/plain .html .htm .shtml .php <br> <br> # Don’t run arbitrary PHP code. <br> php_admin_flag engine off <br> <br> # If you’ve other scripting languages, disable them too. <br> </Directory> <br> <br> <br> <br> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <br> <Directory “/usr/lib/cgi-bin”> <br> AllowOverride None <br> Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch <br> Order allow,deny <br> Allow from all <br> </Directory> <br> <br>
<br>
<br> ErrorLog ${APACHE_LOG_DIR}/error.log <br> <br> # Possible values include: debug, info, notice, warn, error, crit, <br> # alert, emerg. <br> LogLevel warn <br> <br> CustomLog ${APACHE_LOG_DIR}/access.log combined <br> <br> Alias /doc/ “/usr/share/doc/” <br> <Directory “/usr/share/doc/”> <br> Options Indexes MultiViews FollowSymLinks <br> AllowOverride None <br> Order deny,allow <br> Deny from all <br> Allow from 127.0.0.0/255.0.0.0 ::1/128 <br> </Directory> <br>