355968cf7f51fa3c05edbef9a2380b3343f1b46f
By:
kooperg

Remove Password on main site (not just the wp-admin area)

February 11, 2015 1.7k views
code

Hi, I get a "restricted Area" login prompt (which i can bypass with the provided WP admin password) at my entire website. I checked the Removing the Additional Apache Password Prompt for Admin Areas GUIDE, but my apache file looks really different, see below.

Can anyone point me to what I should change/remove/# ?

Thanks a lot!

ServerRoot "/etc/apache2"
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel crit
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf

<Directory />
    Options FollowSymLinks
    AllowOverride None
    <Limit PUT DELETE CONNECT OPTIONS PATCH PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
        deny from all
    </Limit>
</Directory>

<Directory /var/www>
        Options FollowSymLinks
        AllowOverride FileInfo
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>


AccessFileName .htaccess

<FilesMatch "^\.ht">

2 Answers

You can removed "restricted Area" log in using .htaccess file. You can locate it in root directory of website.

I typed nano .htaccess and all it shows me is a (new) empty file...

I didn't login as root tho (since that's disabled per the guide)... and when I add 'sudo' it tells me my account is not a sudoer...

  • Ok, I regained root... ^^

    I just #-ed out all the wordpress stuff in the .htaccess file...

    Still, I get the pop-up asking me for login (which accepts WP admin password only)

    Is there anything else I need to do? Is this a standard WP thing,,,?

Have another answer? Share your knowledge.