Question

Remove URL extension with a2enmod rewrite with htaccess

Hi there :-)

I am trying to enable the URL rewrite so that when a person goes to http://sitename.org/home.php they will not see the extension or .php .

I cannot get it to work unfortunately, this is what i have done:

I think I must be missing something small here:

#my htaccess:

RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME}.php -f RewriteRule ^(.*)$ $1.php [L]


#set permissions to 664

#a2enmod is enabled

#removed extension from links in code (changed link in nav menu form /home.php to /home)

#restarted apache

when i got to …/home - i get a 404.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Make sure that you have AllowOverride set to All in your apache virtual host file.

<Directory /var/www/html>
        Options -Indexes +FollowSymLinks +MultiViews
        AllowOverride All
        Require all granted
</Directory>

And then restart apache.