Question

Restarted Droplet - Wordpress won't start (Page won't load)

Hi all,

Hopefully someone can help, I (Maybe foolishly) restarted the droplet via reset the root password page.

Since then my Wordpress has failed to load, when accessing via SSH it would appear Wordpress is installed I just cannot browse to the site/ip anymore.

Can anyone advise on steps to take at all?

Thank you!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I mean you will most likely have a stack running on the server of different things that work together to host your site.

It sounds like you have LAMP which stands for:

Linux (Where your typing commands in terminal) Apache (Hosts the web files and serves them) MySQL (For databases) P (For PHP)

It sounds like Linux is fine. Apache: sudo service apache2 status Type that in command line and it should say it is running if it does not then thats where your problem lies and can go forward from there. MySQL: If your site is using a data base type in command line: sudo service mysql status it should say something along the lines of it is running or not again that may be where your problem lies. PHP: Is a bit more static I think, so basically there is no way to tell if this is up and running unless the site is up and running, I think?..

Is it not connecting to a website address in the browser or an IP address it would help if you could provide them and I can then see what its doing exactly? It could be your DNS settings.

Hi SomeT.

Yep, tried in Icognito/browsers etc.

TBH, my knowledge of SSH/Ubuntu service is slim at best, I have run ‘Sudo service apach2 start’ which doesn’t return any error - Unsure on how to check PHP?

Thanks for the advice!

Have you tried to access it in incognito mode? Any further details you can provide will help me to give you a solution. Have you checked if apache or other web server is running? PHP running etc…?