Question

Restarting ghost on Ubuntu 14.04 throws errors

  • Posted September 23, 2014

I have an installation of Ghost 0.5.1 on Ubuntu 14.04. I made changes to the config.js so the home page points to my IP address. I tried to restart npm but I get the following errors:

npm ERR! ghost@0.5.1 start: node index npm ERR! Exit status 8 npm ERR! npm ERR! Failed at the ghost@0.5.1 start script. npm ERR! This is most likely a problem with the ghost package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node index npm ERR! You can get their info via: npm ERR! npm owner ls ghost npm ERR! There is likely additional logging output above. npm ERR! System Linux 3.13.0-24-generic npm ERR! command “/usr/local/bin/node” “/usr/local/bin/npm” “start” npm ERR! cwd /var/www/ghost npm ERR! node -v v0.10.30 npm ERR! npm -v 1.4.21 npm ERR! code ELIFECYCLE npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /var/www/ghost/npm-debug.log npm ERR! not ok code 0 root@ghost2:/var/www/ghost# cd root@ghost2:~# nano npm-debug.log root@ghost2:~#

In npm-debug.log

0 info it worked if it ends with ok 1 verbose cli [ ‘/usr/local/bin/node’, ‘/usr/local/bin/npm’, ‘restart’ ] 2 info using npm@1.4.21 3 info using node@v0.10.30 4 verbose config Skipping project config: /root/.npmrc. (matches userconfig) 5 error Error: ENOENT, open ‘/root/package.json’ 6 error If you need help, you may report this entire log, 6 error including the npm and node versions, at: 6 error http://github.com/npm/npm/issues 7 error System Linux 3.13.0-24-generic 8 error command “/usr/local/bin/node” “/usr/local/bin/npm” “restart” 9 error cwd /root 10 error node -v v0.10.30 11 error npm -v 1.4.21 12 error path /root/package.json 13 error code ENOENT 14 error errno 34 15 verbose exit [ 34, true ]

Any ideas?

Best

Tom

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

There is an error in your /root/package.json

I’d recommend using the Package.json validator to see if it can spot the error for you.