Question

Result is not as described in the published guide.

Following this tutorial, https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-16-04, I have done everything exactly, including the server setup guide at https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-16-04, and at the first launch of the application: manage.py runserver, it runs the server, but visiting that particular ip address and port 8000 gives absolutely no response. Has there been changes in versions that have made the above documentation obsolete? Or maybe a step that needs to be done but hasn’t been included? I’ve tried 5 times now on 5 new droplets, following the documentation exactly… So first we call rule out typo’s and such…

Subscribe
Share

I still have the same problem, but did manage to get Django installed and working with the steps I put on this post on stackoverflow: https://stackoverflow.com/questions/46644774/deploying-django-to-a-server/46659873#46659873

Yes, I systematically went through all of the comments, but none of the solutions, or adaptations to my own problem worked. Because I cannot get Django to display on accessing the server, I will today read ahead and understand how nginx connects to the project with gunicorn, because my other servers running nginx to serve angular applications work perfectly.

Hi Konghai,

There seems to be a fair few comments on that article:

How To Set Up Django with Postgres, Nginx, and Gunicorn on Ubuntu 16.04

Perhaps the solution lies in one of those somewhere? Unless you’ve been through these already. There are a fair few with similar (although I don’t know if identical) issues in there. It could be one of those?

Just to reiterate - scroll down past the end of the above guide, and you’ll see many of the user comments and the problems they ran into.

Did you try any of these already?

Best of luck.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!