I can not connect with my MongoDB from my Macbook.

Versions on my machine:

  • macOS Catalina 10.15.4
  • Robo 3T 1.2.1

Versions on Digitalocean machine:

  • Ubuntu 20.04
  • MongoDB shell version v3.6.8

I am trying to connect with ssh. I check ‘Use ssh tunnel’. I add the IP address with the port 22. With the user root and I add the private key from my machine.

I have another machine with Ubuntu 16.04.6 and I can connect.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hi there @mikelgarciaurbina,

What is the exact error that you get when you try to connect?

Also, have you tried following the steps from this tutorial here on how to configure remote access:

https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-mongodb-on-ubuntu-16-04#part-three-configuring-remote-access-(optional)

Regards,
Bobby

by Melissa Anderson
MongoDB is a document-oriented database that is free and open-source. It is classified as a NoSQL database because it does not rely on a traditional table-based relational database structure ... In Part One of this tutorial we'll use the MongoDB Repository to install the latest version of MongoDB. In Part Two, we'll enable authentication to secure it on the local system. Finally, in Part Three, we'll show how to more securely allow remote connections if they're needed.

Hi @bobbyiliev,

The error is when trying to connect from ssh:

Info: Creating SSH tunnel to ID_ADDRESS:22…
Error: Resource temporarily unavailable. Error when starting up SSH session: -8
. (Error #35)

I tried to configure ufw. I tried to disable ufw. I tried to configure nginx. I tried to disable nginx.

I never have a ssh connection from robo 3t. But I can access it from the terminal with the ssh command.

I don’t know what else to try.

I’m update robo3t to version 1.4 it work fine

Submit an Answer