Question

Robo 3T not work on Ubuntu 20.04

I can not connect with my MongoDB from my Macbook.

Versions on my machine:

  • macOS Catalina 10.15.4
  • Robo 3T 1.2.1

Versions on Digitalocean machine:

  • Ubuntu 20.04
  • MongoDB shell version v3.6.8

I am trying to connect with ssh. I check ‘Use ssh tunnel’. I add the IP address with the port 22. With the user root and I add the private key from my machine.

I have another machine with Ubuntu 16.04.6 and I can connect.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @mikelgarciaurbina,

What is the exact error that you get when you try to connect?

Also, have you tried following the steps from this tutorial here on how to configure remote access:

https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-mongodb-on-ubuntu-16-04#part-three-configuring-remote-access-(optional)

Regards, Bobby

I’m update robo3t to version 1.4 it work fine

Hi @bobbyiliev,

The error is when trying to connect from ssh:

Info: Creating SSH tunnel to ID_ADDRESS:22… Error: Resource temporarily unavailable. Error when starting up SSH session: -8 . (Error #35)

I tried to configure ufw. I tried to disable ufw. I tried to configure nginx. I tried to disable nginx.

I never have a ssh connection from robo 3t. But I can access it from the terminal with the ssh command.

I don’t know what else to try.